Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a production 8.4 service and a dev 8.4 service. They have been running solidly, but the past two weekends, the production service has randomly stopped running, this week on Sunday, last week on Saturday, not during any particular event or scheduled job. The dev service, however, was fine.

This seems out of order, but according to the event logs, first pgAgent shuts down ("Failed to query jobs table!"), and then 8 seconds later postgres shuts down. Both weekends it happened in that order. I would expect, if anything, that postgres shutting down would cause pgAgent to then shut down. I guess, if it got stuck on something that took >8 seconds to kill it, maybe at some point it would cause pgAgent to no longer work, before postgres fully died.

In the postgres logs themselves, there's this error:

FATAL: pre-existing shared memory block is still in use

...which according to this post could be related to antivirus software. We run Symantec, and resource hog it may be, I certainly am not going to leave the system unprotected as the post suggests. Any other suggestions?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I'm not sure what's up with postgre itself, but you could always use something like Service Hawk to monitor the service to keep it running.

share|improve this answer
1  
Nice util. Thanks! –  Kev Oct 19 '09 at 15:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.