Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is the information displayed by the wireless router (see end of post). The problem is that my netbook does not get any signals from the router if moved more than 3 feet (yup, three feet) away from the router. Please outline steps that I should try on the router and/or the netbook to improve signal strength on the netbook. A CAT5 connection to the router works perfectly but its not "portable".

screen1

screen2

screen3

share|improve this question
1  
Make sure to test with another PC or wireless card to make sure it isn't a problem with the card. Could be a loose connection or even teh antenna became detached. –  Dave Drager Oct 19 '09 at 18:50

7 Answers 7

up vote 2 down vote accepted

Have you tested with somebody elses wireless first? Narrow down first if its your netbook or if its the access point. just going to a coffee shop or someplace with free wi-fi will work, if it works there then you can look at the access point, otherwise the issue is the netbook.

share|improve this answer
    
Appears that something is wrong with the router (LinkSYS dd-wrt) -- not sure what it is though. Other (borrowed) router worked fine. –  Salman A Oct 20 '09 at 7:50
    
Always the simple answer. Try loading a new firmware on the device, if that doesn't cut it I would say its a bad unit and just replace. –  Shial Oct 20 '09 at 13:17
    
The firmware is about 3 years old. Is it a bad idea to load a new firmware? Some people say so. –  Salman A Oct 21 '09 at 4:57
    
well since the unit isn't working anyway whats there to lose? –  Shial Oct 21 '09 at 5:13

Reposting the InSSIDer link because it's the first place I go to find out what the wireless landscape looks like. This will give you a bit more information also about what's happening to the signal the netbook is receiving.

share|improve this answer

From the settings and diagnostics you are displaying there doesn't appear to be too much of an interference problem - I've certainly seen worse - but that doesn't mean there isn't something bad going on.

Before you start - standard debugging rules apply - change one thing at a time and if it doesn't work then revert to the default setting before trying the next change.

First thing I'd do is focus on the Netbook and check to see if you can force it to use only 802.11b t. If there are options to completely disable power saving on the WiFi adapter on the Netbook then disable it. Likewise if it supports any custom extensions (specifically Cisco's CCX) then disable those. You might want to change the settings and power cycle the system too, just to be certain that the changes are taking effect.

If you can't make those changes or the have no effect move on to the AP. At a minimum though I would leave the Netbook WiFi fixed in 802.11b mode with power saving disabled if at all possible. 802.11g\n operating in the 2.4Ghz band can have a harder time dealing with interference so for the sake of debugging it is a good idea to eliminate the issues that they may introduce from the equation.

Your AP is operating in mixed mode at the moment too so change the Network mode from Mixed to 802.11b only to reduce the impact of interference from foreign 802.11g and 802.11n sources. You also have quite a lot of headroom in terms of Transmit power - try boosting the Xmit Power setting, and raising the noise floor (but be careful there raising it will have an impact on potential throughput). I'm not familiar with your AP but you might have to reboot it after each change.

If you do get things to work in 802.11b mode then try switching over to 802.11n only (if your AP supports it) or 802.11g only on both the AP and Netbook to see if you can sustain the higher signal rates those protocols will support.

share|improve this answer

I'd change the wireless channel first. You may be getting interference from other access points, wireless phones, etc. operating on the same channel.

share|improve this answer
    
I tried from channel 1 to 14, nothing helped! –  Salman A Oct 19 '09 at 16:55

Have you tried changing the channel that the wireless network is on? If another wifi router in your area is using the same channel (frequency) that can cause interference. Also, are there any other electromagnetic generating equipment near the router that could cause interference?

share|improve this answer
    
cordless phone, yes but its in another room. not sure what other devices could cause intererence –  Salman A Oct 19 '09 at 16:56
1  
Microwave ovens are a real killer but they are intermittent, anything electrical with motors might, lighting systems with dimmers, worst I've ever seen was an ion implanter but if you have one of those nearby then poor WiFi is the least of your worries. –  Helvick Oct 19 '09 at 17:54

Might also check the WIFI adapter settings on your netbook and toggle power management mode.

share|improve this answer

As @Chris_K pointed out, is your adapter working well with other APs? Also, do you have any satellite radios nearby? I've found those to disrupt signals. Do you have another laptop or wireless device to test the router? I could also be a deffective router.

share|improve this answer
    
Good point. Unfortunately there is no other equipment around in my home so I might have to take both devices to a friend's –  Salman A Oct 20 '09 at 3:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.