Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Ok, here's the story.

I have a server running FTP 'out there'

I can connect to it using the admin account, browse files, download files. When I try to upload files, I get 550 Access Denied.

I have tried through FileZilla and command line. I have windows firewall turned off (on my machine) I can UPLOAD files from another machine (using the same admin account) on our local network (that means, same public IP)

what is the problem?

I am running Windows 7, Build 7100 and the other machine on the network is running XP SP3

The thing that gets me though, is that this worked for the last probably 4 months, without a problem, I get back in the office after a weekend today and it won't work...

share|improve this question

migrated from stackoverflow.com Oct 19 '09 at 16:48

This question came from our site for professional and enthusiast programmers.

    
I don't have an answer but only a suggestion. If it is not secure ftp, try sniffing traffic using a packet sniffer such as SmartSniff or ethereal in both machines to see what exactly goes over the wire while you try the ftp, the difference should have the answer. –  Murali Oct 19 '09 at 5:42

5 Answers 5

A common problem I have had with Windows boxes and FTP access, is that the local account I set up to log in via FTP on the target box does not have the "do not expire" checkbox checked. So basically it has expired the FTP account password, and wants it to be changed - but that can only be done manually, not through FTP.

That is the default state for new accounts created on the system and it must be changed manually (even the command line option /noexpire does not work on MS Server 2003 and below).

That might be your problem. To fix it, someone with admin access on the FTP target server has to login and check the "do not expire" checkbox for your FTP login account.

Ron

share|improve this answer

I have experienced a similar problem before like this before, my colleague set me up an account on his FTP server.

He could access and upload the FTP server using his laptop and his account from our work ext IP, when I tried using my computer with my account and the same ext IP it wouldn't upload.

He tried my account on his laptop and it worked fine.

I played about with alot of the settings but I believe that when I changed my network location in Windows 7 to Home as it was set to Public that's when it started working again for me.

Again not the exactly the same problem but it obviously has something do with Windows 7

share|improve this answer

Windows 7 blocks access to active ftp by default. Please check if these steps take care of the issue.

Open Services.msc

Find Application Layer Gateway Service

Select Automatic and start the service.

Try accessing the ftp server.

share|improve this answer

Looks like you don't have write permission. You may need to contact your system admin. See this page for a brief explanation.

share|improve this answer
    
Albert says he was able to upload using the same admin account from another machine. –  Murali Oct 19 '09 at 5:37

Sometimes some FTP clients change the default chmod before any uploading. If it's not working from that specific computer BUT with the cliens, that means, it's related to the computer's settings. Try to check the log of the computer, and make sure the firewall is turned off (check that throuh services.msc for instance)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.