Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've used adprep on the 2000 SBS, but my 2008 server says run adprep when trying to promote it to DC

share|improve this question

Are you running adprep on the W2K server using the 32 bit W2K8 media? If not, that's the problem.

share|improve this answer
I remember the first time I ever had to do this. The documentation didn't really make it clear that you should use the adprep that was on the installation media of the newer OS on the old server. – Mark Henderson Mar 17 '10 at 20:58

How long did you wait after the adprep? You'll need to restart the (current) AD server or wait 30-90 minutes before promoting.

Also, do you have SP4 on the 2000 server? Did you check the adprep logfile?

share|improve this answer
I do have SP4 on the 2KSBS. I have not restarted the 2KSBS since running adprep, but it was over 24 hours running time before I tried to promote the 2008 server. I will check the adprep log. – Ken Oct 19 '09 at 20:40

Did you run adprep with the /forestprep flag? If you are the only domain, the you are both the domain and the forest, and need the /forestprep flag.

share|improve this answer
I ran adprep with the forestprep, domainprep and gpprep switches in that order. – Ken Oct 20 '09 at 0:34

Verify that you are in windows 2000 native functional mode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.