Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to set up my raid server here at home to use gmail's smtp and an email from my google apps to alert me if there is any issues.

I set up ssmtp, here is my config:

# Config file for sSMTP sendmail
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=email@gmail.com

# The place where the mail goes. The actual machine name is required no
# MX records are consulted. Commonly mailhosts are named mail.domain.com
mailhub=smtp.gmail.com:587

# Where will the mail seem to come from?
#rewriteDomain=

# The full hostname
#hostname=ALEXANDRIA

# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
#FromLineOverride=YES

UseSTARTTLS=YES
UseTLS=YES
AuthUser=email@gmail.com
AuthPass=****

But every time I try to send I get this error:

ssmtp: Authorization failed (454 4.7.0 Cannot authenticate due to temporary system problem. Try again later. 14sm88672bwz.5)

I have logged into the account via web, it is not locked down.

Please help me out, I have spent too long trying to figure this out already.

share|improve this question

closed as off-topic by Sven Dec 7 at 2:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Sven
If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers 4

The answer is that I had special characters in my email address.

share|improve this answer
    
What sort of special characters? –  Bill Weiss Oct 19 '09 at 22:17

Looks like Gmail is having a problem with it's TLS auth. I'd do what the message says and try again later. If it persists for a while, then consider bugging Gmail support about it. It certainly doesn't seem like it's anything wrong with your end.

share|improve this answer

This should be simple as with this old article: http://www.sysadminsjourney.com/2008/09/01/use-gmail-as-an-smtp-relay-using-ssmtp archived here: http://web.archive.org/web/20090104204332/http://www.sysadminsjourney.com/2008/09/01/use-gmail-as-an-smtp-relay-using-ssmtp

You are probably not correctly specifying your email or password. (Which is seems I guessed correctly)

The article basically said this:

Use GMail as an SMTP relay using SSMTP

Posted Mon, 09/01/2008 - 21:05 by Justin Ellison
On some of your home workstations, and especially on a laptop, setting up a full-blown SMTP server such as Postfix, Sendmail, or Exim might be overkill. Follow the jump to learn how to setup the lightweight ssmtp to relay all outbound mail through your GMail account by using Gmail as a smarthost.

SSMTP is meant to be a no-frills, secure, and lightweight replacement for a full-blown MTA. Personally, I feel it's best use is on a laptop where you're moving around between networks a lot, and need to send outbound emails from cron or other shell scripts.

By setting up SSMTP, it doesn't matter where you are, sending mail will be sent out over encrypted SMTP to Google's gmail servers. After handing it off, Google's servers do all the routing for you.

Setting up SSMTP is quick and easy - let's get to it. On Ubuntu, run:

sudo apt-get install ssmtp mailx

Now, we just need to configure SSMTP. Open up /etc/ssmtp/ssmtp.conf in your favorite editor, and add or update the following lines:

#The following line redirects mail to root to your gmail account
root=myemail@gmail.com
mailhub=smtp.gmail.com:587
UseSTARTTLS=yes
UseTLS=yes AuthUser=myemail@gmail.com AuthPass=mypassword

That's it! Now, let's try testing it:

echo "This is a test message." | mailx -s 'Test Message' myemail@gmail.com

You should now be all setup and ready to go!

share|improve this answer
    
The link is dead. –  Joel Coel Mar 8 '13 at 20:46
    
@JoelCoel That is sad; try: web.archive.org/web/20090104204332/http://… –  dlamblin Mar 28 '13 at 15:56

Apparently Google has an interest in verifying some accounts and puts a capcha in the log-in block. Log in to your google account and go to this page to turn of the capcha:

https://accounts.google.com/DisplayUnlockCaptcha

share|improve this answer