Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How can you solve the error message at the last line?

....
# Installing MediaWiki with php file extensions
# Environment checked. You can install MediaWiki.
#

Generating configuration file...
# Database type: PostgreSQL
# Loading class: DatabasePostgres
# Attempting to connect to database "wikidb" as "wikiuser"... error: No database connection
# Checking the version of Postgres...
Warning: pg_version(): supplied argument is not a valid PostgreSQL link resource in /var/www/wiki/includes/db/DatabasePostgres.php on line 1078
FAILED. Required version is 8.1. You have 7.3 or earlier

I am using Postgres 8.3 which makes the error message strange. The file "LocalSettings.php" was not created to the directory config so I cannot continue the installation without solving the problem.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

the error message only says that the script tried to call pg_version() with a wrong type. So there was no Information returned about your PG Version an I assume the script only gives a Default error message, with a "custom" version number.

The Script gets an error and infact it requires Version > 8.1 it assumes that maybe the connection Problem is related to a Version prior to 8.1, so it calls pg_version(). But you never had a Database connection. And so you get this warning.

Has nothing todo with the Version you are using.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.