Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've configured my httpd.conf using:

Directory "/Users/GMan/Public/Source/LC2">

I've stopped the apache server with:

apachectl stop

And then restarted it with:

apachectl -f /path/to/my/httpd.conf

And yet when I browse to my ip:

http://1.1.1.1

I see the default index.html which contains:

It Works!

I'm using a Mac with OS 10.5. I am totally stumped and would appreciate some ideas!

G-Man

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

The <Directory> directive you quoted above does not tell Apache where the root of your website is in the filesystem. Instead, it's a way to specify different options, permissions, etc for certain directories.

You need to look into the DocumentRoot directive. That tells apache where to look for your files.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.