Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am almost certain that even the VMware knowledge base omits denoting exactly where the config.ini is supposed to be for Vmware Workstation 6.5 on 64-bit Windows 7 host. Several references to kb.vmware.com are provided by Toan Tran. What am I missing? By the way, I am trying to get rid of the "VMware Workstation has measured your CPU speed to be xxx MHz but Windows reports that it is xxx" message.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

@rasx,

I ran across your question while looking for the same thing. I hope you've found the answer otherwise but here is the solution if not. This is for VMWare Workstation 6.5 on Windows 7 Pro x64.

1) Close Workstation.

2) Use a command prompt to change directory into: "c:\users\all users\vmware\vmware workstation\" 3) Enter "notepad config.ini"

4) Enter the following 3 lines (cpukHz is true Mhz x1000)
host.cpukHz = "3599000"
host.noTSC = "TRUE"
ptsc.noTSC = "TRUE"

5) Save and exit. Then restart the VMWare Authorization Service.

You shouldn't see the error any more and the guest OS clock should be accurate.

Jeff

share|improve this answer
    
I don't have this directory on my Windows 7 64-bit system: c:\users\all users\vmware` (nor do I have c:\users\all users`). Does this suggest that I should make these directories manually? –  rasx Feb 1 '10 at 18:10
    
It is a hidden system folder - it's there you just don't 'see' it. Paste the following into a command prompt: 1) cd "c:\users\all users\vmware\vmware workstation\" (include quotes) 2) notepad config.ini 3) Enter values per #4 above –  Jeff Hengesbach Feb 2 '10 at 17:05
    
Got it! Sorry for my late response... –  rasx Apr 7 '10 at 2:18

I don't have a version of Windows 7 installed anywhere to test but this article seems to explain it.

The config.ini file may not exist if you have not changed the default configuration setting from the Edit > Preferences menu. ...

Notes: ... On Vista and newer versions of Windows, look for the file at C:\Program Data\VMWare\\Config.ini

share|improve this answer
    
you might want to test out your answer... –  rasx Oct 20 '09 at 17:10
    
Why would I setup a system to test it when you have already have that and the motivation to figure it out. If my answer is invalid or didn't work for you, then you might want to provide a useful comment or update your question describing what did not work. –  Zoredache Oct 20 '09 at 18:11
    
All of the file locations listed in the article you site do not work. You should be able to extract literally from my question what I consider a solution to this problem. –  rasx Oct 30 '09 at 18:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.