Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using Exchange 2007 and we've never assigned mailbox storage limits, many users will have old mail that can now be removed. How can I assign a storage policy and have it enforce it?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Disk quotas.

Exchange Management Console > Server Configuration > Mailbox. Look for the Mail Store to manage, right click, go to Properties and set the limit there under Limits.

share|improve this answer
    
Thanks Randolph –  Steven Oct 20 '09 at 9:13

You can enforce mailbox quotas at two levels in Exchange 2007:

Database Level

You can set the mailbox quotas at database level, so these apply to all mailboxes in that database (unless overridden at the mailbox level).

To do so in the Exchange Console, go to server configuration, then mailbox. Select the mailbox database you want to set quotas for, right click and go to properties. Select the limits tab, then enter the values you want.

To do the same with the Exchange Shell, issue this command:

 Set-MailboxDatabase -Identity <"Server\MailboxDatabase"> 
-IssueWarningQuota <2000> -ProhibitSendQuota <2500> 
-ProhibitSendReceiveQuota <3000> -QuotaNotificationSchedule 
 "Sun.2:00-Sun.3:00","Wed.2:00-Wed.3:00"

Replacing the values in <> with your values

Mailbox Level

You can enforce individual mail quotas at the mailbox level, so each mailbox can have a different quota, if needed, or you can override your database level quota for specific mailboxes.

To Set this using the Exchange Console locate the mailbox in the recipients configuration section, right click the mailbox and to properties. Select the Mailbox Settings tab, then click storage quotes then properties. In here you can set the warning, prevent send and prevent send & receive limits.

To do the same using the Exchange Shell, issue the following command:

Set-Mailbox -Identity <user@domain.com> -IssueWarningQuota <2000> 
-ProhibitSendQuota <2500> -ProhibitSendReceiveQuota <3000> 
-UseDatabaseQuotaDefaults $false

Replacing the values in <> with your values

share|improve this answer
    
Be careful with your units. Explictly suffix the quota numbers with KB or MB so you don't have any accidents. e.g. "-ProhibitSendQuota 2500MB". Also do note that Exchange gives status mesages to the user in MB, so, if you promise "100MB", you need to either put (1024 * 100)KB to be true or "100MB" when you setup the quota. –  Brian Desmond Oct 31 '09 at 18:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.