Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This happens on a number of PCs (WinXP SP3), where an application will simply lock up. It may be the browser (usually Firefox in our case) or it may be Visual Studio, or something else, but every time it seems the same, the application locks up, sometimes for minutes. There is no spike in CPU usage. Usually the other applications that are open at the time continue to work fine, but other times it takes the explorer.exe process with it.

Given the lack of CPU spike, or any other metric I can see, how can I diagnose what is causing this issue?

share|improve this question
add comment

5 Answers

up vote 1 down vote accepted

It could be a network problem, the clients may have trouble resolving names (netbios and dns) or simply trouble accessing network resources and hence anything that accesses files for instance may appear to freeze waiting for various timeouts to end.

Simple things like having roaming user profiles on a file server with some folder redirection and a "faulty" network with a malfunctioning or misconfigured switch may cause delays and user interface response issues for several minutes in Windows if it's part of a domain. Since Explorer.exe is mentioned as a frequent casualty it's not too far-fetched I guess.

Does it happen or gets resolved if you unplug the client from any network connections (so those connections actually gets closed on the client)?

Does it happen if you log on as a local user instead so no user-level group policies gets applied?

share|improve this answer
    
This solved it. I cut the network connection & explorer comes back & everything works fine. –  Glenn Slaven May 15 '09 at 15:41
    
Cool, I'd love to hear if you find the source of the problem later on ^^ –  Oskar Duveborn May 15 '09 at 15:52
add comment

You might want to look into 'Process Explorer'. This free app will allow you to see all the in's and out's of what is happening on the system. It should give you a good look at what is hanging up while the program is running.

Download Process Explorer here

share|improve this answer
    
I'm running process explorer, unfortunately it's not enlightening me either. –  Glenn Slaven May 14 '09 at 23:24
add comment

What anti-virus are you running? I have seen this problem before with Norton, when it gets into its head that a process is a virus and grabs onto it for minutes at a time before deciding that it's not a virus.

share|improve this answer
    
HP Protect Tools Security Manager –  Glenn Slaven May 13 '09 at 5:29
    
I admit to having zero familiarity with that security suite, so this advice might be totally worthless, but I would still recommend trying to disable the anti-virus on one machine and seeing if that clears up the lockups. Since you have multiple applications locking up, it means its not just one thing causing the problem. Further, since you have it happening on multiple machines, it means not a hardware problem. One of the remaining universals is your security product. –  Happy Hamster May 13 '09 at 5:46
add comment

Though it's not completely fleshed out yet, this question has a good starter list. You're going to need to find a smoking gun in the event logs or through eliminating startup items, unless you can find a trend in similar apps/hardware to narrow it down.

share|improve this answer
add comment

Check the following

  1. If you have 'Roaming Profile" check the server hosting the profiles. Look at the event logs on that server (System Node) for hardware errors. Check the network cable etc.

  2. Check DNS. This will lead you to Domain Controller(s). Check event logs on that server as well. Verify proper network connection.

  3. Check your switches. Sometimes this can cause periodic hicups (if it's a managed switch) and you have some misconfiguration, like storm control setting.

If this happens once in a while, I've often seen DNS as the issue. Sometimes running a "dcdiag" on the domain controller fixes the issue.

One last quirk I've seen is if the clients are mapped to a printer which is no-longer in service, Ive seen the apps take a while to load. By just removing that printer from the "printers" section has also fixed this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.