Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Logged in as root, I installed the php-gd libraries using

$ yum install php-gd

it said everything worked fine, so i did

$ /etc/init.d/nginx restart

But the code I had been working on still complained of not having the gd libraries and when I went to check the output of phpinfo there was no 'gd' section.

I should note that yum list | grep gd shows

gd.i386  2.0.33-9.4.el5_1.1  installed
gd-devel.i386  2.0.33-9.4.el5_1.1  installed
gdb.i386  6.8-27.el5  installed
gdbm.i386  1.8.0-26.2.1  installed
php-gd.i386  5.1.6-23.2.el5_3  installed

I also added extension=gd.so manually to /etc/php.ini and it is still not showing up or raising an error which leads me to believe my php.ini is not being re-parsed when I restart nginx. Is there something outside of restarting nginx I have to do to get php.ini changes loaded?

I have a fair amount (like 3 years) of ad-hoc server administration experience although no formal training, but I'm relatively new to nginx and have never worked with CentOS before, so any help would be much appreciated.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

How are you running PHP? If you're running it in FCGI mode with an external spawner, restarting nginx will have no effect on the PHP server, so you'll need to restart that separately.

share|improve this answer
    
yeah it appears that I am actually, that must be it. Any idea where I would look to restart the spawner? Here is the nginx configuration fastcgi_pass unix:/tmp/php-socket; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME /var/www/crushitcharity$fastcgi_script_name; include fastcgi_params –  Neil Sarkar Oct 20 '09 at 21:47
    
nevermind I found the script in /etc/init.d/fcgi-php thanks for all your help! –  Neil Sarkar Oct 20 '09 at 22:00

Beginner linux user question:

I also am getting the "in phpinfo there was no 'gd' section" but I seem to have GD and its gd-devel installed.

How do I know if am using FCGI. Maybe I need to restart my FCGI? Goes restarting the entire computer restart FCGI?

Thanks

share|improve this answer
    
First, check to make sure there is a gd.so line in your php.ini, then you need to restart whatever process is executing the php. Chances are you are using a standard LAMP system so that would mean restarting apache. To see if fcgi is running, issue a ps aux | grep cgi and see if there are matching enries –  Neil Sarkar Jan 12 '10 at 17:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.