Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to use Group Policy Preferences to manage user connections to shared printers.

The print server is Windows Server 2003 R2 Std edition. Several printers are installed, and I've added x64 editions of all the drivers to the print server as well.

I've created a new GPO containing the printer preference settings. Printer mappings are targeted based on AD security group membership.

I log on to a Windows XP PC with the Group Policy CSEs installed and the printer maps perfectly.

I log on to a Windows 7 x64 PC and it doesn't map. If I manually connect to the shared printer, I get a prompt which asks me to confirm if I trust the server before installing the driver, and then it works perfectly.

I have domain admin rights and my UAC settings have not been changed from the default, i.e. UAC is enabled and the default level is selected.

Is the printer mapping failing because it's unable to prompt me to install the driver, or is there something else afoot?

share|improve this question
    
what exactly do you mean in '.. and my UAC settings are untouched' Have you disabled UAC? –  Julius A Oct 21 '09 at 12:46
    
I have not changed the UAC settings from the defaults. Edited the question to clarify. –  ThatGraemeGuy Oct 21 '09 at 13:24
    
Perhaps a silly question, but are the 64 bit drivers installed on your print server? –  Zoredache Oct 21 '09 at 16:56
    
@Zoredache: yes, I said that in the question. I'll update the wording to make it clear. –  ThatGraemeGuy Oct 21 '09 at 19:29
add comment

2 Answers

up vote 8 down vote accepted

OK I managed to get this working.

For Vista there is a Group Policy setting (more info here):

  • User Configuration/Policies/Admin Templates/Control Panel/Printers

Configuring the "Point and Print Restrictions" policy setting to "Disabled" will allow for silent printer driver installation, and thus allow the printer to be mapped successfully.

After struggling for the better part of this morning trying to figure out why this didn't work on Windows 7, I eventually discovered that Windows 7 and Server 2008 R2 ignore this policy setting. There is an equivalent setting under:

  • Computer Configuration/Policies/Admin Templates/Printers

This is honoured by Windows 7 and Server 2008 R2 See TechNet for more info.

share|improve this answer
add comment

If you cannot find the policy under Computer Configuration, you may not be using Group Policy Management on Server 2008 R2. You'll only get the policy on Server 2003 if you have updated your ADM files to the latest.

If you are having the reverse problem with XP clients, make sure you have followed this article: http://support.microsoft.com/kb/888046

Method 1 worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.