Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem where I cannot completely download a certain file from a server.
The file is 1.9MB in size but only 68% is downloaded and then it hangs.

I tried and these cases, which failed:

  1. Downloaded the file with HTTP
  2. Downloaded the file with FTP
  3. Moved the file to different FTP and web servers behind the ISA firewall
  4. Tried with IIS 6.0 & IIS 7.0
  5. Multiple download clients. Which included FireFox, FileZilla (on Windows) and wget (on Linux)

This worked:

  1. Downloading other files from the same location on the server. Both bigger and smaller and in size than the original. FTP and HTTP worked.
  2. Earlier version of this file (.DLL) works. It is as if the content of this file has an influence on this file being served.

Network architecture:

Client Machine -> Internet (ISP) -> ISA Server -> IIS 7.0

The only constants are the ISP, Cisco router and the ISA server. Is it possible that something is rejecting the download because of the contents of the file?

I am hoping ISA is the culprit... I am not a ISA expert is there somewhere I can look to establish if it is indeed ISA causing this?

Update:

  1. Splitting the file into two parts with a hex editor results in one half of the file being served correctly and the other part not.
  2. Zipping the file results in the file being downloaded successfully. However this is not an option for this particular scenario.
  3. Renaming the file and its extension also doesn't work.


Update 2009/10/22:

It does NOT seems to be ISA that is causing this problem. We connected a laptop (running IIS) on an available public IP and still the file download to 68% before it hanged. The two remaining components are the ISP and the Cisco 800 series router. Anyone knows about an issue on the router perhaps?

share|improve this question
    
What version of ISA are you using? –  squillman Oct 21 '09 at 14:10
    
The version is ISA 2004 –  Philip Fourie Oct 21 '09 at 14:34
add comment

4 Answers 4

Are you filtering any keywords in urls or contents?

Perhaps try encrypting the offending file in a zip or rar archive, and then downloading it?

share|improve this answer
    
@Garrett, No filtering on keywords in URLS. Where would you filter for contents in ISA, that might very well be causing this issue? Compressing the file works but unfortunately not an option for this scenario. –  Philip Fourie Oct 21 '09 at 19:47
    
Try checking out the file types filter –  Garrett Oct 27 '09 at 17:39
add comment

Are you running any sort of IPS on the Cisco? That can be the cause of unexplained drop-outs, especially if its always the same "bit" :)

share|improve this answer
1  
I'd look carefully at this as well. We've found our 'intelligent' protection systems will flag up and drop connections for large downloads quite frequently. All you seem to need is a particular sequence of bits in a particular order and the firewall will drop it like it's hot. –  Chris Thorpe Jun 16 '10 at 0:13
    
..especially given it is narrowd down to the cisco or the ISP - my money's still on the Cisco, but could be ISP level IPS, though that would be unusual IME. –  Tom Newton Jun 21 '10 at 13:09
add comment

i have met something similar than this case try to check : 1- Access lists on the router 2-check the connection time out on the server and the client

share|improve this answer
add comment

We got a partial answer on what is causing this.

After resetting the Cisco router the file is now being downloaded successfully. I am guessing that is likely that this will resurface again in the future - after enough traffic has passed through the router.

It would really be helpful if someone can point us into a direction where to find the root cause for this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.