Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying for a 'while' to get this bug out ...

In a fresh minimal install of jaunty; apt-get install xinetd vnc4server openbox. Edited a service file in /etc/xinetd.d/Xvnc : service Xvnc

{ 
        type = UNLISTED
        disable = no
        socket_type = stream
        protocol = tcp
        wait = no
        user = root
        server = /usr/bin/Xvnc
        server_args = -inetd :1 -query ::1 -geometry 800x600 -once -fp /usr/share/fonts/X11/misc -DisconnectClients=0 -NeverShared -securitytypes=none -extension XFIXES
        port = 5901
}

Set up a xstartup file in ~/.vnc/xstartup :

#!/bin/sh
openbox-session &
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &

All i get is a grey screen (old X style) whenever i try changing any option, tweaked over and over.

But,

If i simply run a :

vncserver :1

I'm able to connectm xterm shows .. etc.

Any idea ?

share|improve this question
    
Ok, the more I play around with this, the more I think xinetd is the wrong particular hammer for this problem. Any particular reason you're using it over just, say, starting vncserver in rc.local? –  Jeff Snider Oct 22 '09 at 2:55
    
Mmh not sure to get your idea; i'll have let's say 100 users; each user will have his own 'desktop', they'll connect using a web browser (java vnc); i'll limit access to the browser with username password; each user will have his own vnc port (launched by his own vnc instance). See ? –  Disco Oct 22 '09 at 8:29

1 Answer 1

up vote 2 down vote accepted

I think you need to set up a display manager such as GDM. When Xvnc is starting up, it tries to communicate with a running display manager via XDMCP. That's what the -query ::1 option is in your xinetd file. I've set up GDM on Hardy before, and it worked pretty well. Give this a try:

Install GDM if it's not already installed.

Edit /etc/gdm/gdm-cdd.conf:

  • In the section [xdmcp], set the Enabled option to true.
  • In the section [daemon], set the RemoteGreeter option to the same as the Greeter option. This isn't strictly necessary, but it's prettier.

Restart GDM.

Then try connecting again. You should see a login screen where you can enter your username and password. If that doesn't work, try changing -query ::1 to -query 127.0.0.1. It may be having trouble with IPv6.

share|improve this answer
    
Thanks for the answer; my concern is memory; i'd like to use the minimal environnement, i think setting gdm will add extra useless memory. I added the ::1 because of this post (ubuntuforums.org/archive/index.php/t-795036.html). Why is it working when running from command line and not from xinetd; that's the question :) –  Disco Oct 21 '09 at 20:05
    
Oh one more thing; i don't want users to 'login' to their account providing username and password; this setup is for a kiosk, will let users only login and use some applications, for example firefox –  Disco Oct 21 '09 at 20:14
    
If you don't want to use a display manager, then you shouldn't use -query. That's what that is for. Remove that and change the user field to the user where you were running vncserver. –  Jeff Snider Oct 21 '09 at 20:17
    
Tried; still getting the grey X display ... –  Disco Oct 21 '09 at 20:26
    
is there a 'tool' or how to find out what's going wrong ... nothing in logs –  Disco Oct 21 '09 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.