Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a user in our office who recently reported that Outlook 2007 is having trouble displaying newly arrived messages. If he changes to another folder and then comes back to the inbox, the messages show up immediately.
Environment

  • Windows XP SP3
  • Office 2007 build (12.0.4518.1014)
  • Pop3/SMTP account

His outlook.pst is large (~2.2GB), though we have many other users with .pst files bigger without this trouble.
Googleing suggests that an add-in like Google Desktop or MS Search could be causing the problem. He has never had any extra add-ins installed... Just in case, I have disabled all the build-in add-ins from the trust center, except for VBA, which is required for some auto-updating spreadsheets we use for contact management...
Any ideas would be appreciated.

share|improve this question
    
Was the PST created in Outlook 2003+? –  user3914 Oct 21 '09 at 20:20
    
No, but it was imported from a 2003 .pst. Why? Is there a known issue with a 2003 .pst file in 2007? –  Scott Lundberg Oct 21 '09 at 20:36
add comment

4 Answers

up vote 1 down vote accepted
+100

1) Does the user have Google Desktop Search installed? If so, disable the outlook add-in and restart Outlook.

2) Can you do an update to Office 2007 SP2?

3) A farfetched answer I've heard is that the user must be a participant in the Customer Experience Improvement Program. Close Outlook, open Word, click the office button, click Word Options, click Trust Center, click Trust Center Options, click Privacy Options, and select the option for the Customer Experience Improvement Program (4th option). Then close Word and restart Outlook.

share|improve this answer
    
Good catch on #2. He indeed did not have SP2 installed even though we are using WSUS, his machine apparently failed to install it or he canceled it. Points are yours. –  Scott Lundberg Nov 17 '09 at 21:46
    
Who would have thought it? This worked for me: > 3) A farfetched answer I've heard is that the user must be a participant in the Customer Experience Improvement Program. Close Outlook, open Word, click the office button, click Word Options, click Trust Center, click Trust Center Options, click Privacy Options, and select the option for the Customer Experience Improvement Program (4th option). Then close Word and restart Outlook. –  user118975 Apr 27 '12 at 8:55
add comment

I've seen similar problems in the past arise from the use of the "Used Cached Exchange Mode" setting. You can find the checkbox for that on the Account Settings/Microsoft Exchange Settings page in the Outlook config.

In the environment I was in, any user that had that setting turned on would have to manually check for new messages, via folder switching or "Send/Receive" whereas anyone without the setting saw mail the second it hit their inbox.

share|improve this answer
    
Thanks for the suggestion, but... We are not using exchange. This is an Internet mail Pop3/SMTP setup. I don't have a Microsoft Exchange Settings page. –  Scott Lundberg Oct 21 '09 at 20:48
1  
Ah, forgive me. When I think "Outlook" I immediately think "Exchange." Shouldn't have made that assumption! –  kingfish Oct 21 '09 at 20:57
    
No Problem....... –  Scott Lundberg Oct 27 '09 at 21:38
    
It was helpful for me anyway! Thanks kingfish! –  Exile Mar 7 '12 at 11:56
add comment

I had the same exact problem, My outlook inbox would not automatically update when someone would send me an email. I would have to manually update the folder via Send/Receive.

I unchecked the "Use Exchange Mode", shut outlook down, restarted, rechecked to "Use Exchange Mode" and everything is flowing in flawless!

share|improve this answer
add comment

Copy the PST as a backup.

Anytime things get flaky w/ Outlook it's a fast test to recreate the Outlook profile. Set up the new profile with an incorrect pswd until you have connected the existing PST, otherwise you can end up with dupe msgs.

If this fixes it then rename the .NK2 file to the new profile name and you're done.

If it's still happening:
Confirm the drive hasn't been compressed or isn't running out of space.
Confirm only 1 AV/anti-malware/anti-spyware app is running.
Disable AV temporarily.
Test - if OK now then resolve AV issue or:

Close Outlook
Run ScanPst, fix errors.
Compress the PST.
Test.
Restart AV.
Test.
Clean up the backups, it's easy to end up with 8GB of PSTs laying around.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.