Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am connected to a DSL connection that if connected directly to my computer I get the IP address of 192.169.1.47 w/ a gateway of 192.168.1.1. I would like to connect my Linksys wireless router to this connection.

The problem seems to be that my wireless router uses the same IP sub of 192.168.1 as the network I'm on. I can change the local IP of my router to something other than 192.168.1.1, but I can't set it to give out anything but 192.168.1.* addresses.

I'm pretty decent w/ networking, but this is beyond my experience. Does anyone know of a way around this?

Please let me know if I need to clarify anything.

THANK YOU!!!

share|improve this question

migrated from stackoverflow.com Oct 22 '09 at 3:38

This question came from our site for professional and enthusiast programmers.

    
You want your external IP address? Just curious but why? –  cletus Oct 22 '09 at 3:30

4 Answers 4

I ended up setting the wireless router's local IP address to 192.168.2.1 and turning off DHCP.

I then entered a static IP address on one of the systems I need to connect to 192.168.2.2 and set the gateway address to 192.168.2.1.

The wireless modem is still plugged into the WAN port of my wireless router.

I appreciate all of the other answers here. They definitely pointed me in the right direction. Everything is working now.

share|improve this answer

You can probably configured you're linksys to act as the pppoe client, and put in you're username and password and have it simply dial through the modem. Most DSL modems support this, and only act as a router themselves to reduce complexity if you only have a switch or a single computer. This will mean yo're router now terminates the DSL connection, and you shouldn't run into this conflict. To do this, under WAN setup, select pppoe (assuming you're DSL is pppoe based which is the most common I've seen), and enter the username and password from you're service provider.

Another option would be to disable the dhcp completely in the linksys, and just plug the modem into one of the numbered ports (not the WAN port). Thus the linksys will only act as a switch, and the modem will hand out addresses to all clients. This will cause the linksys to not route, but merely switch traffic to the modem interface, which handles getting to the internet. I generally prefer the first option. To do this, find the dhcp settings, and simply disable dhcp.

Last, it is possible to give the linksys an address range on another subnet. You can usually change the device ip to something like 192.168.2.1 and advertise dhcp addresses of something like 192.168.2.50 to 192.168.2.150. To do this, again you need to find the ip address configuration for the management address, as well as the dhcp options.

share|improve this answer

Go to the DHCP settings and change the DHCP range.

share|improve this answer

You need to configure configure a different address on the second router (access point) to use the first router as the default gateway and turn of DHCP. Also join the first router to the second with the LAN points and not the WAN point (you can make the WAN port work but it will be much more painful)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.