Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm setting up a new Windows Server 2008 x64 file server. For Windows workstations everything works as it's supposed to but for OS X workstations it takes more than 30 seconds to even connect to the server. The funny part is that when the connection is established, everything works smoothly.

Also:

  • On our old Windows Server 2003 file server there is no such a problem

  • If I use Terminal.app & mount, the connection is established instantly

  • I've tried googling the problem (of course) and tried stuff like disabling SMB 2.0 on the server side but without success

Has anyone else bumped into this problem and found a solution?

share|improve this question
    
Having the exact same problem :/ –  Aron Rotteveel May 18 '11 at 13:58
add comment

5 Answers 5

The smells heavily of a DNS issue (30 second timeout, then working). I would install wireshark and take a look at what the OS X system is trying to do for that 30 second window. My bet is on DNS of some kind.

share|improve this answer
    
Oh, I should have mentioned this too: if I use server's ip to connect it's still slow. –  Everything's ruined Oct 22 '09 at 13:47
    
Doesn't really rule out a DNS problem -- who knows if Mac OS X is trying to do a reverse and DNS and your DNS servers arn't responding, or it's ignoring the response for some reason. Best to get a packet capture anyway. –  Kyle Smith Oct 22 '09 at 14:11
add comment

I found that when you click Go -> Connect to Server and put in smb://server/share it takes about 19 seconds to bring up the logon prompt.

If I click Go-> Connect to Server and put in smb://server:139/share it takes about 4 seconds to get the logon prompt.

Give this a try and see how it goes.

Adrian Page

share|improve this answer
    
Don't know if this works for 10.5 but on 10.6 it doesn't :( –  Everything's ruined Nov 23 '10 at 9:25
add comment

Any resolution to this one? assuming it's a DNS issue, what is the resolution? Is it simply that the proper reverse dns entries don't exist and need to be created?

share|improve this answer
add comment

I can't +1 this because I am new here. Someone please +1 this for me, as I too am having this annoying problem.

A network trace does show a few bits of DNS traffic taking 30 seconds...

share|improve this answer
add comment

I totally forgot about this thread but after I recovered my account to comment another thread I remembered.

The solution was to create a file /Library/Preferences/edu.mit.Kerberos with content:

[libdefaults]
default_realm=foo.local
dns_fallback=no

You need to restart os x before it has any effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.