Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been testing my SMTP setup on IIS6 today. I have created a test.eml file that I palce in my pickup directory and it gets sent out. However, when I put a bad address into the file it is not going into the badmail folder. The file disappears and it seems to be removed from the file system.

Thanks

share|improve this question
    
Shouldn't be CW, and belongs on SF –  Gurdas Nijor Oct 22 '09 at 21:33
    
Huh? I don't understand... –  DDiVita Oct 22 '09 at 21:54
    
I've seen this issue, but wasn't able to resolve it –  splattne Apr 1 '10 at 8:22
    
From the help:"Badmail directory: When a message is undeliverable, it is returned to the sender with a non-delivery report (NDR). You can designate that copies of the NDR are sent to a location of your choice. All NDRs go through the same delivery process as other messages, including attempts to resend the message. If the NDR has reached the retry limit and cannot be delivered to the sender, a copy of the message is placed in the Badmail directory." Is the message meeting these configurable conditions? –  mbrownnyc Sep 9 '11 at 20:03
add comment

migrated from stackoverflow.com Oct 22 '09 at 21:54

This question came from our site for professional and enthusiast programmers.

1 Answer

In Exchange 2003 SP1 Microsoft made changes to the badmail folder that effectively disabled it due to the fact that it would fill up, unbeknownst to the sysadmin, until all available drive space was consumed. I don't know if there was a complementary change to IIS but you can check for the existence of the following registry key value:

HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing|MaxBadMailFolderSize

If it exists and the setting is 0, then badmail queueing is disabled and all message that wind up there are automatically deleted.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.