Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having problem with running Apache2.2 on my Vista machine. When I clean install Apache it works just fine, but after I installed PHP, I'm getting this error message in logs.

[Fri Oct 23 21:29:02 2009] [warn] pid file C:/Dev/Apache2.2/logs/httpd.pid 
overwritten -- Unclean shutdown of previous Apache run?

Apache service was stopped when installing PHP. I did only one shutdown before instalation via Apache Service Monitor.

Deleting httpd.pid and starting again doesn't help. I even tried to lookup process with PID in that file, but there is no such process.

share|improve this question

closed as too broad by Tom O'Connor Aug 6 '13 at 7:17

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I am not totally sure what the issue is... need more information to solve this. Try increasing the loglevel in Apache and post more detailed logs. But from what you posted my guess is that Apache is crashing with PHP installed, probably due to a misconfigured or mismatches library... –  Josh Oct 28 '09 at 16:57

1 Answer 1

up vote 4 down vote accepted

As pointed out by some posters - the problem is caused because by default php.ini has not commented out all the extension modules.

I installed php-5.2.13 on Vista Home and experienced the exact problem that Darth came across.

The only extensions I needed were...

extension = php_mysql.dll extension = php_mysqli.dll

The rest, I commented out by placing a ";" a start of each line.

This got Apache starting for me.

share|improve this answer
    
I had the same problem previously, it is caused by some php extension module were not loaded properly. I commented the module loading to prevent this error, as i don't need them time being. If you have to run that module, maybe you have to check the documentation of installing the module. hope it helps. –  Alvin S.J. Apr 27 '10 at 3:31
    
I solved it by removing php_pgsql.dll-module from the php.ini file. –  benep May 5 '10 at 16:34
    
Thank you, this solve my problem as well. I installed Apache2.2, mysql, and php During installation of PHP, I added all the extension. –  Harry Sep 8 '10 at 7:59
    
I solved this problem on my installation by commenting the line ;extension=php_sybase_ct.dll To see which dll causes the error on your windows machine just try to launch php.exe and it will tell you which dll raises an error. –  user83961 Jun 8 '11 at 17:04
    
If you dont know which extension you need you can comment out everything and try to run your application (process). It will prompt for the required extension to be present. Just uncomment it and it will run. –  user146736 Nov 23 '12 at 9:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.