Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I enable remote connections on an SQL Server 2008 installation?

I have created a rule in the windows firewall to allow traffic through port 1433, but that does not seem to be enough.

share|improve this question
1  
Hmmm.....even after following all the tips in this, I still can't connect to my SQL server remotely! –  Sam Schutte Dec 19 '09 at 1:08

2 Answers 2

up vote 9 down vote accepted

Sql Server Configuration Managaer

  • Sql Server Network Configuration

    • Protocols for MSSQLServer

    • Enable TCP/IP

Also in SQL server Mgmt Studio on the server

  • Right click the server
  • Properties
  • Connections
  • Make sure "Allow remote connections to this server" is checked
share|improve this answer
    
Spot on! That worked! :) –  Kjensen May 13 '09 at 14:34
    
Other think that should should see is of the Broker Service is ON. –  Jedi Master Spooky May 13 '09 at 15:43

If it's a named instance, you'll also want to set the TCP/IP port to a static value and enable that in the firewall. Otherwise it's a dynamic port, meaning it could change over time.

share|improve this answer
    
You'll also want a static port if you're using impersonation as the delegation trusts require a port number when set up in AD. –  squillman May 13 '09 at 14:59
    
Actually, if you want to use Kerberos in any capacity, to include just authentication. –  K. Brian Kelley May 13 '09 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.