Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just logged in to my newly purchased VPS server that used debian and tried to install apache2, here what happens as a root:

vs12-101:/# apt-get install apache2
Reading package lists... Done
Building dependency tree... Done
apache2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
6 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up ssl-cert (1.0.23) ...
hostname: Unknown host
make-ssl-cert: Could not get FQDN, using "vs12-101".
make-ssl-cert: You may want to fix your /etc/hosts and/or DNS setup and run
make-ssl-cert: make-ssl-cert generate-default-snakeoil --force-overwrite
make-ssl-cert: again.
/usr/sbin/make-ssl-cert: line 74: mktemp: command not found
dpkg: error processing ssl-cert (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postfix:
 postfix depends on ssl-cert; however:
  Package ssl-cert is not configured yet.
dpkg: error processing postfix (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of at:
 at depends on exim4 | mail-transport-agent; however:
  Package exim4 is not installed.
  Package mail-transport-agent is not installed.
  Package postfix which provides mail-transport-agent is not configured yet.
dpkg: error processing at (--configure):
 dependency problems - leaving unconfigured
Setting up klogd (1.5-5) ...
Stopping kernel log daemon... failed!
Starting kernel log daemon...

and after it stays like this forever, please help me to fix the issue.

Regards

share|improve this question
add comment

1 Answer

The critical line is probably this:

/usr/sbin/make-ssl-cert: line 74: mktemp: command not found
dpkg: error processing ssl-cert (--configure):
subprocess post-installation script returned error exit status 1

That means that the configuration of ssl-cert failed because the command mktemp is missing. To fix, try installing the package mktemp. Then do

dpkg --configure --pending

to finish configuration of all unconfigured packages.

Even so, this is weird. mktemp is marked "essential" in Debian, meaning it should always be installed. Did you use some --force option to dpkg or apt-get? Something seems to be messed up on your system.

share|improve this answer
    
It is actually a fresh debian. the issue is , when I do "apt-get install mktemp". it still gives me "invoke-rc.d ssh restart".I am confused :( –  Hellnar Oct 26 '09 at 14:48
    
I'm confused as well. Please post the complete console output of "apt-get install mktemp" (edit your question). Then maybe things become clearer. –  sleske Oct 26 '09 at 16:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.