Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to create a static route on a Baystack 5510 Ethernet Routing Switch with the following:

ip route 192.168.104.220 255.255.255.255 192.168.100.253 en

I'm getting the following error:

Cannot find entry to modify.

What am I missing?

share|improve this question
    
Have you tried adding the route without enabling it in the initial command? I've seen that error before but it was a fairly old code revision where we had that happen. –  sparks Oct 26 '09 at 17:00
    
I have tried that - it then says "% Incomplete command." –  jjrab Oct 26 '09 at 17:48
add comment

2 Answers

up vote 1 down vote accepted

Jim - I just got the same error with the latest code. Did you ever get it working?

I will answer my own question:

Despite what the syntax says with "?" use:

ip route x.x.x.x y.y.y.y d.d.d.d 1

The '1' is for a the cost. Just like a router but you have to entre it, not an option.

share|improve this answer
add comment

Could you verify that no route exists with

show ip route 192.168.104.220 -s 255.255.255.255
or
show ip route static

Also if you haven't configured any routing on the switch so far you can manually enable IP routing globally before trying to add the route with the following:

ip routing
ip route 192.168.104.220 255.255.255.255 192.168.100.253

You don't specify if you're trying to route a specific vlan or not, but you will have to have an assigned IP on the VLAN(s) you wish to have routing on.

share|improve this answer
    
I've added routes on this before, but I can't remember what I did differently. I do not have this particular route configured however, it's a new entry. I have 3 VLANs and all 3 are configured with IP's –  jjrab Oct 26 '09 at 16:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.