Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Ubuntu (Ubuntu 8.04.3 LTS) running in a VMware Fusion VM, and I'm sharing my Mac's home directory using Fusion's sharing feature. I've created a subdirectory in my home directory and used the Finder's Get Info (and "Apply to Enclosed Items") to give read & write access to "Everyone". But when I (or a program) create a sub-subdirectory in Ubuntu, I (in Ubuntu) don't get read access:

drwxr-xr-x 1 1818155768 302979775  68 2009-10-26 14:20 temp

(This is a line from an ls -l in my VM, after mkdir temp.)

Is it possible to configure the VM (or the Linux guest or the Max OS X host) so directories are created with write access? How?

Update: I created a /temp directory on my Mac and shared it in Fusion with read & write permission. Then I did the following:

$ cd /mnt/hgfs/temp/
$ ls
$ mkdir foo
$ ls -l
total 1
drwxr-xr-x 1 1818155768 80 68 2009-10-27 17:21 foo

As you can see, foo was created in the (Ubuntu) VM, but the VM doesn't have write access.

share|improve this question

2 Answers 2

Try setting the uid= option when mounting hgfs - example on the web here. You probably want the uid set to whatever your uid in ubuntu is (id to find out).

Alternatively if you wanted every folder you made to be mode 777, that's umask. I'm unclear when you talk about the "vm not having access" - the VM has access, but not your account.

share|improve this answer

Did you set the shared folder to "Read & Write" in Fusion's preferences? And you do have VMware tools installed and up to date right?

EDIT: After ensuring that the VMware tools are installed properly, try a reboot of the virtual machine to ensure all modules are loaded properly.

If that doesn't work, try creating a new shared folder, maybe on the root of your Mac's hard drive, and see if you can share that Read/Write. This will help determine where the problem is.

EDIT2: If you're able to mkdir foo, then the VM has access to the shared folder. Can you do the same thing in your home directory?

share|improve this answer
    
I do have it set to "Read & Write". But I ran into a problem installing tools: serverfault.com/questions/78757 –  Daryl Spitzer Oct 27 '09 at 16:40
    
Ah ha, that's probably what the issue is. –  Josh Oct 27 '09 at 17:00
    
I'm both skeptical and hopeful. –  Daryl Spitzer Oct 27 '09 at 17:17
    
Does this work after installing VMware tools? –  Josh Oct 27 '09 at 19:42
    
No, I'm still having the same problem. But I'm not sure VMware Tools is properly installed. See "Update 3" in my question in serverfault.com/questions/78757. –  Daryl Spitzer Oct 27 '09 at 20:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.