Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get TS gateway going on a 2008 Server. I'm running into trouble with authentication. I found that I needed to enable Windows Authentication in the RPC site. While Windows Authentication is enabled the RD gateway works flawlessly. After about 5 minutes though it appears to reset to disabled. I've looked high and low and can't find a setting to make it the default or to keep it from inheriting some parent object's settings. Any ideas? I'm assuming it's more of an overall IIS7 thing than just the RPC site not playing nice.

share|improve this question
up vote 0 down vote accepted

That sounds really odd. If you set a setting in IIS, that becomes the fixed setting. Inheritance just means that it's not set at a particular level. It's not something that would reset after a few minutes.

My best guess is that some other application is checking the IIS site settings. Or, do you don't happen to be using shared configuration or have any type of software that would replace applicationHost.config every once in a while? i.e. a robocopy or xcopy push from another server?

Some things to check are: - Event viewer for any clues - watch the time stamp on applicationHost.config to see if it changes after a few minutes - using process monitor ( set a filter for applicationHost.config and watch it to see which application is changing the setting back.

share|improve this answer
Well I feel dumb. I swear I looked through Event Viewer and didn't see anything. I saw that the file changed back after changing it again right at 9pm this evening. In the Application log I saw an event about Outlook Anywhere checking/changing Rpc over http authentication settings, so that did it. Thanks for the advice and confirming I'm not just crazy. – maik Oct 28 '09 at 4:08
Sometimes it helps just to talk it out with something. Glad you were able to figure it out. That could have been a tricky one. – Scott Forsyth - MVP Oct 28 '09 at 4:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.