Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to move from NetRestore to DeployStudio for my dual-boot Apple deployments, but I'm not sure how to remove NetRestore from my NetBoot server. When I NetBoot a client, it still launches NetRestore automatically and does not launch DeployStudio. I believe I have DeployStudio installed correctly on the server and my repository is mountable from clients.

share|improve this question
up vote 2 down vote accepted

Both DeployStudio and NetRestore have a NetBoot image that is created to launch the actual DeployStudio or NetRestore application to copy the image over. In the NetBoot section of Server Admin you want to disable the NetBoot image that has NetRestore installed on it (and once your migration is done you can remove it since it won't be needed) and make your DeployStudio NetBoot image the default.

If necessary you can recreate the DeployStudio NetBoot image by running the DeployStudio assistant again. You can also use from Your Mac Guy which also continues to work even if NetBoot stops working until you can restart the server.

share|improve this answer
Thanks! The option to disable the NBI is unavailable ("greyed"), so I deleted that NBI file from the Resources directory and refreshed the service. I no longer get the "attempt to insert nil value" error I was getting, but there is still no Start button for the service and most of my options are still unavailable. I am going to try to reinstall DeployStudio and see if I can get the service to start. – Doug Chase May 13 '09 at 18:27
After reinstalling DeployStudio, the NetBoot service will not start and I'm getting an error dialog that reads, "NIL_RESPONSE_ERR(""" -[NSCFDictionary setObject:forKey:]: attempt to insert nil key)." Any ideas? No NBI seems to have been created by DeployStudio, so the list under the Images tab in Server Admin -> NetBoot -> Settings is still empty. – Doug Chase May 13 '09 at 18:31
Ick. NetBoot isn't happy. Have you tried manually starting it via serveradmin start netboot or check it's status with serveradmin status netboot? The easiest fix is to reboot or use netbootch (See my updated answer for the link) Thread about the error you're getting: Are you running 10.4 or 10.5? For 10.4 Apple has an article on how to reset and 10.5.7 has a fix for the grey NetBoot issue. – Chealion May 13 '09 at 19:41
Chealion, thanks for the help. I have posted a follow-up at if you care to pop over. – Doug Chase May 15 '09 at 12:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.