Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to in stall httpd-2.2.4 on the linux VM. Steps I followed are as follows: 1. Downloaded file: httpd-2.2.4.tar.bz2 2. tar –xvf httpd-2.2.4.tar.bz2 3. cd httpd-2.2.4 4. ./configure

after this when I am trying to compile it using "make" command it is giving me following error:

libtool: link: only absolute run-paths are allowed make[2]: * [htpasswd] Error 1 make[2]: Leaving directory /root/httpd-2.2.4/support' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory /root/httpd-2.2.4/support' make: * [all-recursive] Error 1

How to resolve this problem. I have all the devel packages installed on my machine.

share|improve this question

migrated from stackoverflow.com Oct 28 '09 at 16:00

This question came from our site for professional and enthusiast programmers.

    
Did you pass any specific parameters to ./configure? –  Joe Oct 27 '09 at 14:56
    
yeah i tried with different options it didn't work with any of them. Like: $ ./configure $ CC="pgcc" CFLAGS="-O2" \ ./configure --prefix=/sw/pkg/apache \ --enable-rewrite=shared \ --enable-speling=shared and few more ..... –  Pravin Oct 27 '09 at 15:07

1 Answer 1

seems like a rpath problem... libtool wants the complete path, did you try:

./configure --libdir=/usr/lib/

Try the above config option with whatever your lib path is and post back.. And please post the complete output, i think you may be leaving something out..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.