Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have 2 Exchange 2003 mail servers (mail_old and mail_new) in the same administrative group. mail_new has one user on it, while mail_old has all our other users on it and is internet facing. We use Google's Postini service to send emails out.

The problem we are having is that emails to the user on mail_new are sitting in a queue called mail_new.domain.local, rather than being sent for local delivery.

Using the message tracking center, the following events are noted :

SMTP: Message Submitted to Advanced Queuing
SMTP: Started Message Submission to Advanced Queue
SMTP: Message Submitted to Categorizer
SMTP: Message Routed and Queued for Remote Delivery
STMP: Started Outbound Transfer of Message

Therefore, I think that the problem is that the email should be being queued for Local Delivery, but it's not. Any ideas on how to fix this?

A bit more information. Our SMTP virtual server on both mail-servers use Postini's server as a smart-host. We have 1 SMTP connector with the following settings :

Address Spaces
  domain.co.uk
  domain.local
Connector scope : Entire Organization
Allow messages to be relayed to these domains : unchecked

Use DNS to route to each address space on this connector : checked
Local Bridgeheads
     mail_old "Default SMTP Virtual Server"

Any ideas anyone?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You don't want to specify a smart-host on the SMTP virtual servers. That's what's causing your mail not to be delivered between the servers. You might think that your SMTP connector will "override" the settings on the SMTP virtual servers, but it won't.

Postini has problems taking delivery from an SMTP connector. They aren't actually doing store-and-forward-- they were acting more like a layer 7 proxy between the remote destination SMTP server and your sending SMTP server. If the remote SMTP server had rejects a recipient, for example, Postini will return an error that puts the SMTP connector into retry state, "clogging up" the SMTP connector's queue. They haven't changed this behavior, so you're going to have to go thru stupid configuration tricks to route around their brain-damage.

Edit: Here's some background on what Postini's problem was, historically. I know this was still the case in 2007, but I don't know if they've buckled down and made their service a true store-and-forward service or not: http://groups.google.com/group/microsoft.public.exchange.admin/msg/9155c2fb5a0c3238

Edit 2: Have a look at the guide here: http://www.postini.com/webdocs/outbound/en/outbound%5Fconfig%5Fen.pdf

Postini is still completely brain-damaged and stupid, apparently. They want you go through wild gyrations (and, frankly, they have you screw up how Exchange is supposed to work) to get your mail delivered to them w/o using an SMTP connector in an Exchange 2003 environment because they're STILL not just doing store-and-forward.

Basically, rather than allow you to use built-in functionality in an SMTP connector in Exchange (and allowing the Exchange routing engine to make the best judgements about how to move the mail around between servers in a multi-server environmnet) they want you to create a patchword of SMTP virtual servers with smart hosts enabled and relaying allowed-- in effect end-running the routing functionality in Exchange.

Morons.

share|improve this answer
    
I get the vaguest hint here that you've been personally burned by this in the past... –  RainyRat Oct 29 '09 at 16:43
    
Actually, not "burned", per se-- just annoyed by Postini's abuse of protocol (SMTP) that is clearly a store-and-forward protocol. I had a Customer who had an issue with Postini's brain-damaged behaviour, but it was fairly easy to work around. It just offends my sensibilities when an otherwise intelligent company (Google Postini) does something so mind-boggling stupid. –  Evan Anderson Oct 29 '09 at 17:21
    
Hi Evan - many thanks for that. I think this has caused a lot of my confusion - I would get Exchange properly configured, but then it still wouldn't work. I've got a working setup now, but I think this is still an issue, as occasionally the queues start backing up, and restarting the SMTP is the (quick) fix, which I think fits in with what you're saying. Nice rant by the way :-) –  RB. Oct 30 '09 at 9:12

Regardless of the external provider config, you generally do not want smarthosts configured on the SMTP virtual server. That routes all mail leaving the server through that virtual server rather than leaving the Exchange environment. Instead, set up any needed smarthost on the appropriate SMTP connector for the routing group.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.