Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Every time i go to manage our virtual servers from the web-server, e.g.:

http://atat.consanto.com:1024/VirtualServer/VSWebApp.exe?view=1

it asks me for a username and password. How can i change this? i would rather it didn't ask me for credentials. i would rather it be completely unsecured, and open to anyone.

i realize it's running from IIS, but i cannot find anything that makes it require HTTP-AUTH in IIS Manager. i tried editing security settings, wherever i could find them, to give Everyone Full Control, but didn't solve the issue.

It's running on Windows Server 2008.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

To allow a site, folder or file to run without prompting you essentially need to enter the credentials for the user. This is done with the anonymous user. Since you're using IIS7, what I recommend is that you edit the website -> authentication. Ensure that anonymous authentication is enabled. Then edit it and select the bottom radio button, to use the app pool identity.

Now you need to make sure that your app pool identity user has at least read permissions to disk. Check which user your application pool is running under and edit the permissions on the site folder and ensure that that user is granted access to disk.

If anonymous authentication is disabled, or if the anonymous account doesn't have access to disk, then it will prompt for credentials.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.