Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Windows Server 2008 x64 R2 (I have the supporting hardware for x64), but I keep getting an error saying the device driver for DVD drive is missing.

I downloaded the driver from Dell's site (my PC vendor) and put it on my USB pen and then pointed the installation to this, but the installation could not see the files, just the folder structure. The DVD drive is PBDS DVD+- RW DH-16 W1S ATA Device.

This issue is pretty much the same as this one and also this one.

I did speak to a Windows server engineer at my work and he recommended slipstreaming the installation using vLite. Will this work? This requires WAIK which failed to install when mounted using PowerISO (I will try Daemon Tools now). So as I failed with PowerISO (really annoying as there is some sort of problem at every step but I am progressing), I will try with Daemon Tools now.

This is for a VM (using VMWare Workstation). I get the same issue when burning the installation ISO to disk and setting the PC's boot order to boot from DVD first (to basically do a physical installation).

How can I get by this issue? Does anyone here have experience with this issue? Thanks

share|improve this question
Doesn't Daemon Tools contain bloatware/malware now? I wouldn't recommend using it. – ITGuy24 Oct 30 '09 at 16:14
@ ITGuy24: Not if you get the "lite" version, and make sure you don't install anything other than the core files. – Josh Brower Dec 30 '09 at 1:39
DaemonTools used to be awesome, but since they started putting bloatware in it I just don't trust them, or their ethics, any more. I switched to MagicISO ( with no complaints at all – Mark Henderson Feb 1 '10 at 3:32

When you say that you put the driver on your USB pen, did you extract it? Windows needs to be able to see the inf file and access the driver files from the extracted driver package.

share|improve this answer
The driver is .exe only (I made this original thread). – dotnetdev Oct 30 '09 at 21:22
I'm confused. You can't point Windows at an exe file when it prompts you for a driver. You either have to launch the executable to install the driver or extract it if it's a self extracting executable. Have you tried executing it from another machine to see if it's an installer or a self-extracting executable? – joeqwerty Oct 30 '09 at 21:47
I ran it, and it is an installer. I tried a slipstream with VLite but this failed (unhandled exceptions and stuff). What can I do??!?!! – dotnetdev Oct 30 '09 at 22:40
I should actually try to point to the file the installer puts on my PC, actually. – dotnetdev Oct 30 '09 at 22:44
You could try to exctract it. Execute it from a command propmt like this: C:\>executable.exe /? And see if it has any options for extracting it. Also, what model pc\server is it? – joeqwerty Oct 30 '09 at 23:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.