Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently upgraded to ESXi 4 and I noticed that under the Video Card tab (for VM Properties) there is the option to set 'Maximum number of displays' (1-10) and ability to reserve memory for a given configuration (i.e. color depth & display resolution). This is incredibly exciting for me as the lack of dual monitor support stopped our full adoption of virtualisation. If I am able to get dual monitor support in (1920x1200x32bit) in windows xp (virtualised on ESXi 4 obviously) then I can start to roll out over 20+ vms to take over from our current physical machines.

My problem is that the setting always seems to revert to 'Maximum number of displays' = 1 no matter what settings you pick and when the VM is booted up there is only one monitor available in display properties.

Screenshot of the display settings in ESXi4 that I'm talking about

Can any one shed some light on why the option is there if it is being ignored? This is incredibly important to me personally and any help would be extremely appreciated.

share|improve this question
1  
But how are you going to use that? You can see a VM's desktop only by looking at the console in vSphere Client or by RDP'ing to that machine. In both cases, you get just one window. –  Max Alginin Oct 30 '09 at 16:58
    
Using a tool like TeamViewer you get dual monitor support on a remote machine. It's very cool you should check it out. –  InvertedAcceleration Oct 31 '09 at 14:36

2 Answers 2

Using Remote Desktop Manager you can toggle the RDP flag to enable full screen on both monitors at whatever resolution your monitors run at. This is probably also possible with only the standard Remote Desktop Client, but I use Remote Desktop Manager because it makes the process so much easier.

share|improve this answer

The normal way to interact with virtual machines in ESXi is through Remote Desktop. I'm presuming that the setting has more to do with allocating sufficient memory for the guest so that when you RDP in, you'll be able to access the higher resolution required for dual monitor support.

Have you seen this thread? It talks about the problem of reverting back to one.

Also, it seems that you need to tell your RDP client to use dual monitors. See the following links.

How to use dual monitors in remote desktop session on windows 7

Take advantage of Windows XP Pro's multiple monitor support for Remote Desktop Connection

I hope that helps. I don't have ESXi to test it.

share|improve this answer
    
Great, thanks. Just in case links got broken in the future: On XP host issue from command line mstsc.exe /span and then you can have Remote Desktop Connection spanning all monitors. –  jakub.g Feb 24 '12 at 16:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.