Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a vanilla Windows 2003 SP2 installation (using MS Media) installed on an HP DL380 G6 (using Broadcom nics).

When I boot the machine unattached to a domain, there are no issues. As soon as I join the machine to another vanilla domain server and reboot, I begin getting event id 1053 ("Windows cannot determine the user or computer name. (). Group Policy processing aborted.") logged. The other errors are such that DHCP logs an error that it cannot lease an IP and assigns the default 169 address.

Once the machine is booted, though, and I'm able to log in, the machine has already rechecked and leased it's DHCP address and applied the Group Policies. I will be using this machine to run SQL Server and VMWare vCenter, so I installed those applications and reboot. The above error prevents SQL and vCenter from starting at boot time.

Now, the crazy thing is that if I disable/reenable the NIC and reboot before the NIC recovers it's DHCP lease, the system boots with no error. If I reboot while the NIC is functioning and active, the error manifests itself.

I've read there might be an issue with the Broadcom NICs and Server 2003 SP2, but I've tried the tweaks and they don't seem to work.

Any suggestions would be greatly appreciated.

share|improve this question
    
This is just one of the reasons servers are nearly always configured with fixed IP addresses. –  John Gardeniers Oct 30 '09 at 22:26

2 Answers 2

up vote 1 down vote accepted

A few things I would recommend:

  1. Make sure you have the latest drivers for the NIC.

  2. Enable portfast on your switch port.

  3. Set the "Always wait for the network at computer startup and logon" setting in the registry or alternately in the GPO that applies to the server.

  4. Optionally, disable TCP Chimney Offload and Receive Side Scaling. I've seen these functions cause problems with Broadcom NIC's. the following link is an article that details how to do it in W2K8 but the process is the same for W2K3.

http://support.microsoft.com/kb/951037

My guess is that the DHCP request from the server is timing out before the networking components are fully initialized on the server and before the switch port goes into forwarding mode.

share|improve this answer
    
I forgot to mention that I would recommend you use a static ip address on the server. –  joeqwerty Oct 30 '09 at 23:56
    
+1 for Portfast - Spanning Tree transition periods can be a real annoyance - and on reflection they could easily be all that is wrong here. –  Helvick Oct 31 '09 at 0:52
    
Looks like the problem was Portfast. Thanks –  mgriffin Nov 2 '09 at 13:41
    
Happy to help and thanks for updating us. –  joeqwerty Nov 2 '09 at 16:49

The problem you describe seems to indicate packet loss - probably caused by something going wrong at a fairly low level. Because DHCP uses UDP it is much more sensitive to packet loss the DHCP requests from your server, or the replies from the DHCP server, may be getting lost or mangled which would cause precisely the problem your seeing.

Your interactions with the domain will mostly be via protocols that use TCP - this has error correction built in and the network stack will plug away and retry failed packets so you may not see any obvious failures but if you dig a bit you will probably still see ongoing packet loss and some performance degradation - run Netstat -e from a CMD shell to see what it says, you shouldn't see any Discards or Errors on a healthy network, well not any significant numbers at any rate.

I've had lots of problems with Broadcom Gbit NICs on servers - my standard policy is to set them to 1000Mbps Full Duplex - have the tweaks you've tried included this?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.