Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a Windows 2008 Enterprise 32-bit installation in Terminal Services mode. I have a program that runs locally, but will not run while connected with RDP. When trying to launch it, I can see the program running in the task manager but it never displays to the user. There are no messages, no errors, no nothing other than a process listed in the task manager. There is no indication that anything is happening.

I have installed the program using the "Install Program on Terminal Server" option in the control panel and I have also tried reinstalling it with the "change user /install" mode.

Any suggestions?

EDIT: It works fine in Terminal Server 2003.

share|improve this question
What is "the program"? – Izzy Oct 31 '09 at 19:01
Thomson Baseline - a Financial Services application. – Mr Furious Oct 31 '09 at 20:55
Have you tried installing it while in a RDP session? – Knox Nov 1 '09 at 12:50
Yes, I tried installing it while in an RDP session. It didn't appear to make any difference. – Mr Furious Nov 2 '09 at 15:42
As a side note, it works perfectly in Terminal Server 2003... just not 2008. – Mr Furious Nov 18 '09 at 16:26

Unfortunately, whether or not the application will run in a terminal session depends on how it was written. More than likely, the compatibility issue is due to the code making use of the Global Namespace, which is not allowed any longer for security reasons. I would try modifying the properties of the executable so it runs in Windows XP Compatibility Mode and seeing if that works. There is an excellent Technet blog entry that explains why this happens with legacy applications:

share|improve this answer
I tried XP compatibility mode early on. That's a no-go. I'll take a look at what we need to do to deal with a session 0 problem. – Mr Furious Nov 19 '09 at 1:04

I'm not sure which Windows version you are connecting from. If it is Vista or 7, you will need to use mstsc /admin instead of the command Knox described. If that application works while in the admin session, it is likely that the software requires privledge elevation of some sort.

share|improve this answer
I tried that and I discovered that it DID work (windows 7 client). What do you suppose that means? It will only work with session 0? – Mr Furious Nov 18 '09 at 6:31

It might be useful as a debugging step to connect to the console session (session 0) and see if the app works there. Perhaps the app is inadvertantly hardcoded to work only in session 0. From the client, try

mstsc -v:servername /F -console

as documented in

How to Connect to and Shadow the Console Session with Windows Server 2003 Terminal Services

share|improve this answer
I tried running it through this and it behaved exactly the same. I'm really grasping at straws here. – Mr Furious Nov 2 '09 at 15:54
If you're grasping at straws: Have you contacted the vendor yet? – Chris W. Rea Nov 16 '09 at 14:35
(In fact, does the vendor support your configuration?) – Chris W. Rea Nov 16 '09 at 14:36
I have contacted Thomson, but they're not always the most helpful. They do not support Windows 2008, but they also do not say it won't work. They just won't help. – Mr Furious Nov 18 '09 at 16:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.