Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Recently, I have started receiving the following failure notice from the qmail Mailer Daemon:

Hi. This is the qmail-send program at domain
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

:
./Maildir: No such file or directory
I'm not going to try again; this message has been in the queue too long.

--- Below this line is a copy of the message.

The body of the message that failed to send contains the following:

Dr.Web (R) update details:
Update server: update.us.drweb/unix/500
Update has begun at Sun Oct 25 14:30:02 2009
Update has finished at Sun Oct 25 14:30:49 2009

Following files has been updated:
/var/drweb/bases/drwtoday.vdb
/var/drweb/updates/drwtoday.txt

This seems to indicate that an automated update message from drweb regarding an update that has been made is being written to ./Maildir, which cannot be found.

I am using Plesk. According to http://kb.parallels.com/en/970, notifications can be disabled by making an appropriate change to the database. The row that they refer to did not exist in the misc table, however, and I am reticent to start adding rows to the psa database.

So there are two issues:

  1. I am getting notification of a drweb update, something which I don't really need an email about, and would prefer to disable (and something which I only started receiving recently for no readily apparent reason); and
  2. The notification is failing to send because the ./Maildir directory can't be found
share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Well, your system seems to be set up to deliver to Maildir/ directories, yet whatever user it's being sent to doesn't have one.

Use the 'maildirmake' command, once you've identified what directory it's supposed to be in. For example, if it were fred's home directory, then running:

# maildirmake ~fred/Maildir

(i.e. as root) should do the job.

share|improve this answer
    
Thanks - that solved the problem. The user in question was 'drweb'. The home directory for this user was /var/drweb. This was where therefore where the Maildir directory was created. I then simply had to: # chgrp drweb /var/drweb/Maildir/ # chown drweb /var/drweb/Maildir/ # chgrp drweb /var/drweb/Maildir/* # chown drweb /var/drweb/Maildir/* No longer receiving the failure message. –  Sai Nov 8 '09 at 3:35
add comment

Create /var/drweb/.qmail and pur &root in it. You will receive DrWeb update notification but not the failure notification anymore. I'm also using Plesk Panel and I tried to add that field in the PSA database but nothing changed.

Creating the maildir for drweb will fill your disk in the long distance (DrWeb updates the DB every hour) so set up a cron to clean it up every day. ;)

share|improve this answer
    
Would the correct way to clean up the Maildir be to simply # rm -rf /var/drweb/Maildir/new/* ? It is starting to fill up. Would be good to turn off this notification completely, but I think that would involve modifying the update.pl script, which I would want to avoid. Not sure what a .qmail file does; the procedure I outlined in my comment to the first response resolved the problem. –  Sai Nov 10 '09 at 11:12
add comment

The actual cron job that produces these updates is specified in /etc/cron.d/drweb-update. If you're not using using Dr.Web, you could disable this process by deleting or commenting out the line. If you just want to supress the notices, you can redirect the output of update.pl to a log file by appending >> /var/log/drwebupdate.log or similar to the end of the cron task.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.