Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed a SMTP server on my localhost. Now I want to give host address of that SMTP server to my mail client so that client can send emails to that SMTP server on the same computer.

I have tried "localhost" as the server name with port no. "25" but it is not working.

I am sure that my SMTP server is listening at port 25.

What should be given in the SMTP host field?

I am using Windows XP

I have disabled my firewall

Not sure with ISP blocking. How to find out that my ISP is blocking these emails. If it is blocking, then how to get around this problem.

share|improve this question

migrated from stackoverflow.com Nov 2 '09 at 8:28

This question came from our site for professional and enthusiast programmers.

    
what system is this on (win/linux)? –  zarembisty Nov 2 '09 at 6:52
    
Firewall blocking port 25? –  OMG Ponies Nov 2 '09 at 6:55
    
ISP blockage? 15chrlmt –  LiraNuna Nov 2 '09 at 6:57
add comment

3 Answers

It is possible that something else might listening or using that port as well. Have you tried telnet-ing that SMTP server? I would simply just re-configure the SMTP server to listen on another port that you are sure nothing else is using.

share|improve this answer
add comment
  • Check your anti-virus software - some of them install their own SMTP or block SMTP to prevent SPAM being sent if you get infected.
  • Assuming this is on Windows with the Windows SMTP service - make sure the service is running.
  • Something worth testing, at the command prompt type: telnet localhost 25 and report what it does.
  • Some SMTP software will use (or can be configured to use) a specific IP address on your machine and will ignore 127.0.0.1. Check your IP settings and use the specific IP address.
share|improve this answer
add comment

Try to specify 127.0.0.1 as your SMTP host.

share|improve this answer
    
I have tried that also and it is not working. –  Yatendra Goel Nov 2 '09 at 6:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.