Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a windows 2008 server which hosts the network share \\srvcompany\lib. This share contains several applications needed for the daily business. Every client/user (all win xp) has shortcuts on the desktop to these apps. We have the problem that at several (but not all) clients the apps starts very slowly. If I copy the application's programm files to a local folder then they'll start fastly.

When I watch the memory usage in the task manager on such a "slow" machine while an applications starts I notice that the memory usage grows much slowier than when I start the app from a "fast" machine. But when I copy files with Windows Explorer from this share, the speed is nearly the same. I've also checked the network driver, both tested clients have the same network card with the same driver version.

Has anyone an idea where or what I should check next to solve this problem?

Thanks for answers.

share|improve this question

4 Answers 4

You state that file copies appear to be OK but that doesn't really tell you everything is healthy at the physical level, just that the problems don't significantly affect copying. It's probable that this does mean that the underlying network is OK but you should confirm that.

Run Netstat -e from a command window to get a quick idea if there are physical layer problems. Ideally Netstat will report no errors or discards. You may see some related to valid (physicial) network connections\disconnections but there should never be many of those.

If you are seeing a lot (many 10's and up) then you have a low level problem (at the device driver level, duplex and other NIC parameter settings, physical nic, cable, switch port or switch) and should focus your efforts there before moving up into the more complicated parts of the network stack.

share|improve this answer

Is there any possibility you can run them locally and just access data on the share ?

Are all your client network connections at a minimum speed of 100Mbps ?

Do you have antivirus software on the clients that is set to scan network drives ?

share|improve this answer
    
Thanks for your answer. Yes, all clients have a minimum speed of 100Mbps and we've already deinstalled our antivirus solution (TrendMicro) on the "slow" PCs, but the problem still exists. We could run them locally if we had a tool or something else that would copy the application files from the server to a local dir, for example on every system start (Cause the software developers make many updates per month) I think it would be the easiest solution to write a startup script, or do you have any other idea? –  Snowfox Nov 2 '09 at 10:51

How large are the apps? In other words - is the slowness caused by just transferring bits'n'bytes from the share to your local PCs?

If that's not the case, are the apps .NET apps by any change? You may try to disable .NET security through caspol temporarily to see if that's what's slowing things down.

share|improve this answer
    
The apps are about 30M and aren't based on the .Net Framework. Sure, hosting the apps on the server is always slower than when they are locally, but normally the speed is ok. –  Snowfox Nov 2 '09 at 10:57

You mentioned that the server is win2008, and the clients are Windows XP. You may be observing the clients 'negotiating down' to SMB 1.0, since 2008 supports 2.0 and XP supports 1.0.

Look at this article to see how to disable SMB 2.0 on the server, at least until you migrate to Vista or later on the client.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.