Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just upgraded my Ubuntu server from 9.04 to 9.10 and after about 10 minutes it locks up. It won't respond to ping, can't ssh in and the terminal doesn't accept keyboard input. It does not have X installed. I then reformatted and installed it from scratch with the same results. There are two hard drives, the first is for the OS and the second is for media. The second has not changed, it is an ext3 formatted drive with one partition.

I stopped random services (samba, ushare, transmission-daemon) to see if they were causing the issue, but it still locked up. I did a watch "dmesg|tail" until it locked up, but I didn't see anything.

How can I troubleshoot this further? I don't want to downgrade.

Machine specs: Dell Dimension 3000 Pentium 4 @3GHz 512M RAM

share|improve this question
    
Seems you have a case of notfitforpurpose, sometimes called Ubuntitis –  Aiden Bell Nov 2 '09 at 13:55
    
Very funny :) I'd like to add that my router does have IPv6 enabled even though dmesg says that no IPv6 router can be found. –  Matt Williamson Nov 2 '09 at 16:55
    
Just for sh*ts and giggles, can you leave it running memtest86 overnight, this'll rule out thermal and memory issues –  Dave Cheney Feb 24 '10 at 9:59
add comment

migrated from stackoverflow.com Nov 2 '09 at 13:58

This question came from our site for professional and enthusiast programmers.

13 Answers

up vote 1 down vote accepted

I had the same issue with Ubuntu Server 9.10 (headless setup, Intel graphics). Adding nomodeset option to /etc/default/grub worked fine for me. Don't forget to run

$ sudo update-grub

after all.

share|improve this answer
add comment

Another option is to disable the framebuffer support by adding the nomodeset kernel option in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

The box has been up for more than an hour since disconnecting the display now.

edit: After a day I can certainly confirm the problem has been solved by disabling framebuffer

share|improve this answer
1  
This worked for me! –  Matt Williamson Feb 26 '10 at 2:37
1  
This worked for me as well. Thank you for the fix. –  xeon Feb 26 '10 at 22:49
2  
BTW, it (nomodeset) is not for the traditional Linux kernel framebuffer support, but kernel-mode-setting (KMS) which appears enabled by default in Karmic (9.10) for some cards. kernelnewbies.org/… and workswithu.com/2009/07/15/… –  mctylr Apr 3 '10 at 17:10
    
@mctylr +1, didn't know that, useful extra info! :) –  Sander Rijken Apr 4 '10 at 20:22
    
Remind people unfamiliar with grub config generation: sudo update-grub –  Nerdling Apr 19 '10 at 4:13
add comment

Have you ruled out a hardware issue? I'd suggest trying booting with a 9.04 livecd and leave the computer running for a few hours. If the problem disappears, it's probably a bad driver in the 9.10 kernel or similar.

share|improve this answer
    
The computer ran fine with 9.04 since the day it came out. –  Matt Williamson Nov 2 '09 at 14:19
add comment

It is possible that there is a bug with your hardware, but that would not be my most likely guess. Since the hardware is old, I would guess a hardware problem.

I would run memtest86 to see if there are any memory issues. It could be a heat problem too, but then I would think you wouldn't have been able to get it installed.

Edit:
Oh, I missed the part about the upgrade, so probably not hardware fault if it was working before. I would tail -f /var/log/messages and see if you can catch anything before it locks up.

share|improve this answer
    
I'm trying it out. –  Matt Williamson Nov 2 '09 at 14:22
    
Last meesage before it died. Don't think it's important though. Nov 2 09:15:05 valkyrie kernel: [ 9.866396] type=1503 audit(1257171305.291:16): operation="open" pid=1015 parent=1014 profile="/usr/sbin/mysqld" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/sys/devices/system/cpu/" –  Matt Williamson Nov 2 '09 at 15:00
    
Tried stopping mysqld... no dice. –  Matt Williamson Nov 2 '09 at 15:09
add comment

I have the sam issue and I have the server in another house.. I need to restart it again, last message in kern.log is about the nic;

Nov  2 16:57:29 evo kernel: [   11.854112] type=1505 audit(1257177449.426:11): operation="profile_replace" pid=716 name=/usr/sbin/tcpdump
Nov  2 16:57:31 evo kernel: [   13.816151] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
Nov  2 16:57:31 evo kernel: [   13.816289] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Nov  2 16:57:32 evo kernel: [   15.377338] type=1503 audit(1257177452.951:12): operation="open" pid=847 parent=846 profile="/usr/sbin/mysqld" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/sys/devices/system/cpu/"
Nov  2 16:57:33 evo kernel: [   16.153567] type=1503 audit(1257177453.726:13): operation="open" pid=918 parent=917 profile="/usr/sbin/mysqld" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/sys/devices/system/cpu/"
Nov  2 16:57:35 evo kernel: [   17.538557] type=1503 audit(1257177455.110:14): operation="open" pid=1114 parent=933 profile="/usr/sbin/mysqld" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/sys/devices/system/cpu/"
Nov  2 16:57:35 evo kernel: [   17.726787] type=1503 audit(1257177455.877:15): operation="open" pid=1121 parent=1120 profile="/usr/sbin/mysqld" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/sys/devices/system/cpu/"
Nov  2 16:57:36 evo kernel: [   18.817482] type=1503 audit(1257177456.969:16): operation="open" pid=1141 parent=1140 profile="/usr/sbin/mysqld" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/sys/devices/system/cpu/"
Nov  2 16:57:37 evo kernel: [   18.878522] type=1503 audit(1257177457.029:17): operation="open" pid=1152 parent=1151 profile="/usr/sbin/mysqld" requested_mask="r::" denied_mask="r::" fsuid=0 ouid=0 name="/sys/devices/system/cpu/"
Nov  2 16:57:42 evo kernel: [   24.652044] eth0: no IPv6 routers present

Have never looked in the kern.log before so I have no idea if theese massages are new or common.

I also have some kind o fpentium and 512meg mem, the machine has never failed before, I upgraded it today.

[edit] this is a pure server, no screen, only ssh-access, so I would not blame the graphics drivers.[/edit]

[edit possible fix] Added apm=off nomodeset to the boot options, my grub.lst now looks like this:

title           Ubuntu 9.10, kernel 2.6.31-14-generic-pae
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.31-14-generic-pae root=UUID=0943496f-8c97-4f59-a2c0-4b5fd64e3c40 ro quiet splash apm=off nomodeset
initrd          /boot/initrd.img-2.6.31-14-generic-pae
quiet

And I now have 15 minutes uptime as opposed to max 10 before the change. It apparently has something to do with monitor sleep and as I have no monitor some shit hits the fan. I hope the server keeps on running now (16 minutes :)). There's a bug filed: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/474930 That would be my five cents (18 minutes!). [/edit possible fix]

share|improve this answer
add comment

It's definitly the vga-card together with kernel 2.6.31-xx. I started the machine with monitor attached, everything's fine. Unmount the videocable and wait 10 minute after reboot, frozen! Running the machine with kernel 2.6.28-16 everything's fine When I hit the solution, it will be posted here....

Now I found that the powersaving is the reason for server freezes.

The solution is the following:

Create /etc/init.d/local (or a filename you like..)

Content:

#!/bin/bash

for i in 1 2 3 4 5 6
do
   setterm -blank 0 -powersave off -powerdown 0 >/dev/tty$i
done

The make this script start at system start:

chmod 700 /etc/init.d/local
update-rc.d local defaults 80

After this and a reboot my server is running fine.

share|improve this answer
add comment

In my experience display drivers are a common cause of this. You might want to consider moving to the standard vga driver for a bit to see if the problem goes away.

share|improve this answer
    
He said he does not have X installed. –  Kyle Brandt Nov 2 '09 at 14:01
add comment

A bit of a blind one, should've worked it out far sooner... but just in case anyone else is set up the same, I also get, or believed I had the same problem... but my solution seems a lot simpler than expected.

I usually keep my server without any attached peripherals, no keyboard, screen or anything... with 9.04 that seemed absolutely fine. Or course I connect and managed it therefore over ssh but after 10 minutes or so, after the upgrade to 9.10, all woudl appear to freeze, even singing a ping to the server would come back without response...

After trying all the related fixed, I eventually went to plug a monitor in to possibly work on graphics problem that many people seem to blame for this... before long the problem occurred again and I went to plug in a keyboard directly to the server. At that moment I realised the connection had become active again... Now, I have left the keyboard attached for about 12 hours and I have had no problems so far... Any ideas on why a lack of keyboard could give this effect?

Anyway, I know it likely shouldn't be here, but I though someone may have tried all fixes remotely like myself and would benefit from this.

share|improve this answer
add comment

In my experience nforce chipsets may be the cause. I've had this problem with ubuntu 7.04 on some board with nforce2. It hanged sometimes apparently for no reason. So i've bought new MB, this time with nforce4, new processor, new memory... Now it hangs under 9.10 too but differently. Typically this is without any consistent messages. Sometimes I have those audit messages also during start, but computer can work for days, other times it can hang after several minutes, but last messages are typical.

share|improve this answer
add comment

I ended up giving up and downgrading to 9.04. :(

share|improve this answer
add comment

It's definitly the vga-card together with kernel 2.6.31-xx. I started the machine with monitor attached, everything's fine. Unmount the videocable and wait 10 minute after reboot, frozen! Running the machine with kernel 2.6.28-16 everything's fine When I hit the solution, it will be posted here....

Now I found that the powersaving is the reason for server freezes.

The solution is the following:

Create /etc/init.d/local (or a filename you like..)

Content:

!/bin/bash

for i in 1 2 3 4 5 6 do setterm -blank 0 -powersave off -powerdown 0 >/dev/tty$i done

The make this script start at system start:

chmod 700 /etc/init.d/local update-rc.d local defaults 80

After this and a reboot my server is running fine.

Thank you! I can confirm this works for me, it was driving me mad!

share|improve this answer
add comment

I think it is a 64 bit issue. 32 bit runs fine on the same box but the 64 bit version freezes for me as well. 8.10 did the same thing which is why my other server is OpenSuse. I had hoped to get everything back to Ubuntu with 9.10 but I either have to go 32 bit on my server (which I would prefer not to) or go with another Distro.

As an aside, could it be video card issue if you are in terminal mode only and not running any GUI? That seems unlikely. Mine takes longer to freeze (1-12 hours) but it eventually freezes. It is a web (moodle) server and only boots to Command Line.

share|improve this answer
add comment

protected by Sam Aug 27 '11 at 13:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.