Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to know how to automatically load a kernel module at startup on FC9. All the sites talk about adding an entry to /etc/modules.conf.... But that does not exist on FC9... Instead I have /etc/modprobe.d/ directory... Now, I suppose I need to put a file in this dir for my driver but I have no idea how to write this file... I just need "modprobe name" to be run...

share|improve this question
An alternative, if you need the module all the time and need it early in the boot process is to recompile the Kernel to support the functionallty without the module. This is surprisingly easy to do via make menuconfig. This also doesn't really answer your question, so I'm making it a comment. – JeffG Mar 4 '11 at 21:08

Setup rc.modules like so:

echo "modprobe name" >> /etc/rc.modules
chmod +x /etc/rc.modules

rc.modules gets executed early on in the boot proccess.

Or you can create a file in /etc/modprobe.d if you need to pass in options etc:

echo "options foo bar=1 baz=2" >> /etc/modprobe.d/my-options
share|improve this answer

Took me forever to fine a proper sysadmin alternative to the rc.local hack, but it looks like the proper way to is to load kernel modules on boot in Fedora is to do the following.

echo "modprobe name" >> /etc/sysconfig/modules/name.modules
chmod +x /etc/sysconfig/modules/name.modules

This gets loaded on boot via /etc/rc.sysinit and you can look at it to make sure your version of Fedora works this way.

share|improve this answer

Just put "modprobe name" in /etc/rc.local


share|improve this answer
Generally, it is a bad idea to load a module this way. – Anonymous Dec 3 '09 at 9:21
Depends on the module. If need earlier in the boot process use /etc/rc.modules as James mentioned. – HTTP500 Dec 3 '09 at 19:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.