Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hoping someone can help me with a server issue. Recently we upgraded to the latest apache on 2 boxes within are organisation. One being the master box the other being for failover. The upgrade went fine on the master box but on the failover box apache fails to start with no errors, being output or logged. Both boxes have the exact same configuration so found this a bit strange.

I've reinstalled apache and have been through checking the configs and did not find any obvious errors. Eventally I ran a syntax check on each config file being included and found that one of the files apparently has syntax errors.

Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration

Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration

Invalid command 'GeoIPEnable', perhaps misspelled or defined by a module not included in the server configuration

I've trippled checked all the modules are enabled but it still fails. I've googled the subject of these errors loads but have been unable to fine a solution.

I was wondering if anyone had encountered such a problem before and could point me towards a solution.

Thanks for your help in advance.

P.s:

Apache related versions on server.

ii  apache2                      2.2.3-4+etch10                       Next generation, scalable, extendable web se
ii  apache2-mpm-prefork          2.2.3-4+etch10                       Traditional model for Apache HTTPD 2.1
ii  apache2-utils                2.2.3-4+etch10                       utility programs for webservers
ii  apache2.2-common             2.2.3-4+etch10                       Next generation, scalable, extendable web se
ii  libapache2-mod-geoip         1.1.8-2                              GeoIP support for apache2
ii  libapache2-mod-php5          5.2.0+dfsg-8+etch15                  server-side, HTML-embedded scripting languag
share|improve this question
    
You need to post the relevant excerpts from the configuration where these errors are generated from (not just the lines themselves, but the context within which they're being used (i.e. in a <Directory> <Location> etc.) –  Philip Reynolds Nov 2 '09 at 17:53
add comment

1 Answer

It will be impossible to spot the error without the config files but you have some simple error somewhere in the configs. By simple, I mean something like a <Directory> or <VirtualHost> tag is missing in the config file. This is why it complains. For example, it sees : "Order deny,allow" out of context and reports an error about "Order". "apache2ctl configtest" will output a line number and file name you can use to pinpoint syntax errors.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.