Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed sql server 2005 developer edition on my pc. I am not able to see server in management studio. I installed default instace as an installation option.

share|improve this question

2 Answers 2

You have to register a connection to the server instance in the Registered Servers window or just type the connection information into the connection window that you mention is coming up with you start Management Studio.

The server name in the Connect To Server window remembers your registered connections and previous connections, or you can click <Browse for More> to have Management Studio look for servers to connect to. The SQL Browser service must be running on the server in order for them to be shown in the list, though.

share|improve this answer
I think you're on the right track with the SQL Browser service. I want to say when our group got developer we all installed and nobody could connect to each others local databases and it was because the browser service was turned off by default. –  Mike Thien Nov 6 '09 at 14:23

Run the installer again, and on the "features" page, make sure that you select "Management Tools > Complete". Wording might be a bit off, as I don't have it right in front of me, but you get the picture. I don't believe that it is selected by default.

share|improve this answer
management studio is alreay here. but when i try to connect server, new pop screen come then I am not able to see any server. i try localhost, computer name and all combination but i m not able to find any server on my computer. –  Novice Developer Nov 2 '09 at 21:55
Oh, geez. My bad - must have misread. A few things to SQL Server started (use SQL Server Configuration Manager)...are TCP and Named Pipes SQL browser started? You can use MYSERVERNAME, ., or (local) to connect to a default instance. Suffix non-default instances with \InstanceName (if, in SQL Server Config Manager, the service name has anything other than (MSSQLSERVER) after it, you're running a non-default instance. –  Aaron Alton Nov 2 '09 at 22:15
... TCP and Named Pipes enabled... is usually the cause. Also check your firewall on the machine. –  SpaceManSpiff Nov 3 '09 at 2:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.