Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I consistently come up with "You have new mail in /var/mail/root" message in command line mode of my Ubuntu server. How to disable the new mail messages?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Disabling this setting is easy. Simply include

unset MAILCHECK

in your .bashrc file (for login shell) or .bash_profile (for non-login shells, i.e. ssh) and the message shouldn’t appear.

For me it speeds up login for my linux server and removes clutter.

share|improve this answer
add comment

I think that un-setting the MAIL variable should do the trick.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.