Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Goodmorning, afternoon, evening, night? :D

Recently I was asked to install a SBS 2008 server. Never had any experience with the OS, but was suprised how easy microsoft made installing SBS with all the wizards. Thumbs up for that!

Okay, the situation:

We have 2 locations. One main location, the office and the remote office. The server is located in the office. It will be used for files and exchange. Nothing more.

I already got exchange to work, but now I'm stuck with accessing the files in the remote office. I personally never configured a VPN, other then OpenVPN under linux. I noticed SBS also has a VPN server installed.

When I activate the VPN server, it installes and is configured (long live the wizard). When I'm connecting to it via XP or windows 7, the client quits when building the tunnel. It connects, authenticates and then quits.

I really don't have a clue what's going wrong or if this is even the right sollution to access the files on the server from the remote office. Any advice on this, would be great.

Thanks and greetings from Belgium!

share|improve this question
    
It would be useful if you could provide any error messages or logs for your VPN server. If you don't have it turned on, logging can be enabled by going into the Routing and Remote Access MMC , right clicking and going to the Logging tab. –  Sam Nov 3 '09 at 9:40
    
Win7RC1 says error 800. I'll enable the logging on the server and report back. –  The_cobra666 Nov 3 '09 at 10:10
add comment

1 Answer 1

up vote 0 down vote accepted

I GOT IT :D

Apparently, iptables was blocking the GRE protocol.

To solve it:

iptables -t nat -A PREROUTING -i ethX -p 47 -j DNAT --to your VPN server

iptables -t filter -A FORWARD -i ethX -p 47 -d to your vpn server -j ACCEPT

Opening port 1179 is not enough.

iptables -T nat -A PREROUTING -p tcp -i ethx --dport 1179 -j DNAT --to your vpn server.

Do note, this is because the SBS2008 is behind a NAT linux router.

I can now access the server perfectly!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.