Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are having issues with login scripts not running on Windows 2008 Terminal Server. This is a brand new implementation and they have never worked. The test user in question doesn't have any problems running login scripts on their workstation. I have tried logging into the server directly with their account, but still no scripts run. I have setup a test account with Domain Admins rights in the same OU as theirs and the scripts don't run. I can manually run the scripts from the SYSVOL\\Policies folder and they run fine. The Terminal 2008 Server is in a mixed 2003/2008 domain. The user can run the gpupdate on the server without error. I have also run the Group Policy Results for this user and the terminal server and everything looks good, no errors. Any suggestions?

share|improve this question

Group Policy logon script?

if you run gpresult /z > gp.txt, does it show that the user has processed that gpo and sees the script?

If you're running loopback policy processing in replace mode, and the logon script does not reside in the hierarchy where the terminal server is located, that logon script may not be run.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.