Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a P4 system that I installed Fedora 11 on. It will not boot without a monitor attached. The monitor can be off (not even have power plugged in), but must be attached. Without a monitor the hard disk thrashes around a bit like it's starting up services, but does not get to the point where I can ssh into the box. I have set the default runlevel to 3 and removed the rhgb entry from grub.

Any suggestions welcome.

Edit: I have already set the run-level to 3. The machine boots up fine with the monitor plugged in to the point where I can SSH into it. as soon as i unplug the monitor and reboot, it will not boot to that point.

share|improve this question
add comment

3 Answers

This sounds very odd, especially the powered off monitor part, I would imagine that your problem is somewhere else. However if you plan on booting headless than you don't need to boot X at all, modify /etc/inittab and change the line id:5:initdefault: to id:3:initdefault:

and reboot, or conversely add 3 to the end of the kernel options when you boot through grub.

Lets see how far that gets you. If you have any mechanism to monitor what is happening via the serial port that would be tremendously informative also.

share|improve this answer
add comment

Are you sure your diagnosis is correct?

Correct me if I am wrong, but you are saying without the monitor connected you cannot SSH?

I would assume that SSH has not been configured to start so try these steps:

  1. Connect monitor
  2. Boot into Fedora and login
  3. When at prompt try the following command: chkconfig --level 2345 sshd on
  4. Reboot the server with command: shutdown -r now
  5. Wait for server to reboot
  6. Try using SSH now
  7. If successful, reboot the server and remove the monitor
share|improve this answer
    
O yes he was correct I still have F11 ( 2012 :) and it is driving me mad about the same issue. –  user140907 Oct 13 '12 at 10:28
add comment
up vote 2 down vote accepted

After much trial and error this solved it.

I added the following to my kernel parameters:

nomodeset
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.