Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have NDRs disabled on our Exchange 2007 server to prevent backscatter. Is there any way to enable NDRs only when messages exceed size limits? It can be frustrating for people when their messages don't go through because they are too big but they don't get notified.

By the way, we are also using a barracuda e-mail filter in front of our exchange 2007 server. I don't have a size limit set on the barracuda though, so they will still pass the messages to exchange.

share|improve this question

3 Answers 3

up vote 5 down vote accepted
+75

You should be able to do the following:

From the Exchange Management Console, under Org config -> Hub Transport, On the Actions pane select New Transport Rule. Give it a name and remember to select the Enable box.

Select "when the size of any attachment is greater than or equal to limit" and set this to your delivery limit.

Select "send bounce message to sender with enhanced status code" and set the message to something that communicates the acceptable limit.

Finish and restart the Transport service.

There's a full walk through here.

share|improve this answer
    
In order to do this, I'll have to set my exchange message size limit to something really large, right? It seems if I setup a transport rule to reject a file that is larger than 10MB, and exchange itself has the limit set to 10MB.... and I send a 15MB file... it seems exchange will reject it due to its own message size limits before the transport rule even has a chance to touch the message... and no NDR is sent. –  Brett G Nov 12 '09 at 16:53
    
I don't believe it has to be something really large, just safely larger but I think it's reasonable to have (say) a 15Meg Exchange limit and a 10Meg external inbound limit, E2K7's single instancing saves some space with attachments for internal multiple recipient messages. I don't have access to my lab right now to test precisely how it works unfortunately. –  Helvick Nov 12 '09 at 19:05

On the Barracuda, if you go to the Advanced tab and then Maximum Message Size on Email Protocol and set the size to your required limit, it should reject any inbound email that exceeds that. The Barracuda will close the connection without accepting the email meaning that the Barracuda is not required to generate an NDR. The connection is closed with a "552 Message size exceeds fixed limit" message.

share|improve this answer
1  
Well, I'd be willing to go around the barracuda and set a larger file size limit on it than exchange accepts, so it attempt to send it to exchange and exchange bounces it back with an NDR. Getting back to my original question, is it possible to turn on NDRs only for oversized messages? –  Brett G Nov 3 '09 at 22:49

You could setup a Custom NDR Message to handle this or better still have a look at what Helvick has suggested which is is using Transport Rules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.