Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an interesting problem. One of my clients can't access our file server by hostname. If I open explorer and type \\Server1 all I see is a single folder, but if I type it's IP \\10.10.10.10, I can see all the shares on the machine. I can see that the DNS is resolving correctly. If I ping Server1 it will resolve to 10.10.10.10. What would cause this?

  • The client is running Windows Vista.
  • The server is running Windows Server 2003.
  • He has permissions for all the shares on the server.
  • This is part of an Active Directory domain.
share|improve this question
    
Do you have multiple DNS records for the same server, like an A record and a CNAME record? –  joeqwerty Nov 4 '09 at 1:26
    
Furthermore, do you have a WINS server on the network and if so, are you sure the records are correct –  Wesley Nov 4 '09 at 2:24
    
Yes I have a WINS server, it is configured correctly. My DNS is as well. This is only happening to the one person. There are over 50 other people that can connect just fine. –  BLAKE Nov 4 '09 at 5:41
    
On that Vista machine, do you have 'File and Print Sharing' enabled? –  JohnThePro Feb 8 '12 at 17:39

1 Answer 1

up vote 2 down vote accepted

Can he see the missing shared folders by going to \\server.domain.TLD? For example, in my home network, I'd access one of my machines via its FQDN by typing \\axon.wesleydomain.internal

Try adding the DNS domain suffix in the TCP/IP advanced properties of the troubled computer. That option should be set via DHCP option 015 as a best practice.

Furthermore, have you checked the lmhosts file to make sure nothing funny has been added to it?

share|improve this answer
    
Yes, he can browse to it's FQDN. Also, he is not using an lmhosts file. –  BLAKE Nov 4 '09 at 19:20
    
So he can see all shares if he connects via FQDN but not if he simply uses the netbios name? I'd simply add the FQDN to each PC's DNS suffix list via DHCP option 015. That is a best practice anyway. Or if you don't want to make that sweeping change, then just add the FQDN into that individual PC's TCP/IP properties. –  Wesley Nov 4 '09 at 20:25
    
Using the FQDN is a good diagnostic step, but it doesn't fix the real problem. It is important to fix the real issue because some software (QuickBooks 2012) will choke on drives mapped with an FQDN. –  Nic Feb 9 '12 at 17:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.