Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using JOE Text Editor I feel rather annoyed having to change the Word Wrap settings everytime I edit a document. I am sure there must be a way to define a set of defaults for the whole system once and for all. How can I do this?

share|improve this question
add comment

1 Answer 1

up vote 4 down vote accepted

joe looks for its configuration in two places:

- /etc/joe/joerc
- $HOME/.joerc

There are also variants of these files references when the editor is invokved as jpico, jmacs, etc.

Either edit the global file or copy it to the proper place in your home directory and make sure that you have a line reading "-wordwrap" (presuming you want to enable it) starting in the first column.

You can also override the global settings on a per-file extension basis.

This is valid for joe v3.7; there may be subtle differences if you are running an older version but the specifics for your version should be in the manpage if they differ.

share|improve this answer
    
This is consistent with most programs on *nix. –  Kyle Brandt Nov 4 '09 at 12:53
    
Ya' beat me to it, James. Nice to see that other people use JOE. I've been accused of not being a hard-core *nix user because I don't use emacs (or, ugh, vi), but I do so love the Wordstar key sequences that I've grown accustomed to over the years, and JOE fills that niche well. –  Evan Anderson Nov 4 '09 at 15:02
    
Thnx! Worked like charm! –  clops Nov 4 '09 at 17:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.