Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My web application was running absolutely fine. Just 2 days back, I got an error saying. SERVER APPLICATION UNAVAILABLE

I am pretty certain that nothing was changed on IIS. Unless my automatic Windows updates screwed it up completely.

My event viewer had zillions of following errors in Application category.

aspnet_wp.exe could not be started. The error code for the failure is C0000005. This error can be caused when the worker process account has insufficient rights to read the .NET Framework files. Please ensure that the .NET Framework is correctly installed and that the ACLs on the installation directory allow access to the configured account.

I reinstalled IIS. After installing, i ran aspnet_regiis -i for framework v2 and now it throws error saying - The application could not be initialized properly.

Any ideas what going on?

share|improve this question

migrated from stackoverflow.com Nov 5 '09 at 2:07

This question came from our site for professional and enthusiast programmers.

    
Did you manage to solve your problem? –  Leonardo Feb 7 '10 at 22:24

5 Answers 5

Make sure that your IIS_WPG group has read/write access to your deployment directory

share|improve this answer

Have you tried deleting the application from the application pool and recreating it? Have you customized any security settings? What version of Windows/IIS?

share|improve this answer

Alex,

By any chance do you have Symantec Endpoint Protection version 11.0.5002.333 running on your machines? I saw the same issue being mentioned on Symantec forums.

Just curious? As this update came out along the same time as the Windows Update KB 974417

share|improve this answer
    
Something to do with Symantec Endpoint Protection newer update. Check these links. symantec.com/connect/forums/… symantec.com/connect/forums/… –  svi Nov 12 '09 at 23:36

Check this article: http://support.microsoft.com/kb/2009746. That's caused by KB973917 froom the Dec 09 patching. The error message is a bit different than yours though.

Also, if you recently updated your app pool identity, make sure that your custom app pool identity user is in the IIS_WPG group.

share|improve this answer

I've been fighting this one as well. Assuming it's a 11.0.5002.333 issue. Considering rolling back to an earlier version if that's possible.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.