Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to get information about storage consumption from NetBackup's bplist output. I'm running NBU 6.0MP5 on a RHEL 3 server.

The server is backing up several Solaris, Linux, and Windows machines.

When I use bplist to get information about files backed up on any UNIX machine I get something like this:

# bplist -C unixclient -R 99 -l -s 01/28/2006 -e 01/29/2006 /
drwxr-xr-x test ccase 0 Nov 16 09:28 /l/home2/test/
-rw------- test ccase 4737 Jan 06 17:54 /l/home2/test/.bash_history
-rw-rw-r-- test ccase 104 Nov 11 2004 /l/home2/test/.bashrc

However, when I use it to list files backed up on any Windows client I can't get the user and group information. They both always appear as 'root'. Like this:

# bplist -C winclient -t 13 -R 99 -l -s 02/20/2006 /
drwx------ root root 0 Feb 20 14:26 /C/temp/
-rwx------ root root 41 Feb 20 14:26 /C/temp/asdf.txt
drwx------ root root 0 May 25 2004 /C/temp/CTRMNGR/

Does anyone know why bplist doesn't show the correct user/group for Windows files?

If it can't, is there a way to get that information using another command?

Thanks.

Gustavo.

share|improve this question
1  
If you haven't already, you might want to ask on the symantec connect forums, Stumpr probably knows the answer :-) –  Kyle Brandt Nov 5 '09 at 13:42
    
+1 Stumpr's posted knowledge got me through my first nbu implementation 6 yrs ago. –  damorg Nov 5 '09 at 15:31
    
It looks like this is a limitation of the bplist tool when running against a windows backup, from a *nix system. –  blueberryfields Jan 4 '10 at 19:37

1 Answer 1

Maybe use the -nt_files option?

share|improve this answer
    
This isn't it, tested :-( –  Kyle Brandt Nov 5 '09 at 14:46
    
Nope. This options just changes the way file names are presented in the output, with backward slashes instead of forward ones. –  Gnustavo Nov 7 '09 at 11:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.