Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm getting the following error when I click on any service in the services.msc control:

An error has occurred in this dialog.

Error: 54
Unspecified error.

alt text

This is on Windows Server 2003.

As you can see in the screenshot, the error isn't specifying the line or URL so it's not giving me much to go on.

share|improve this question
    
Try accessing it from another computer and see if you have the same problem. If you don't, then I'd say it's an interface problem and not a server problem. Have you recently updated the server (like installing IE8)? Have you rebooted the server? –  joeqwerty Nov 5 '09 at 13:40
    
Reboot: Yes. Update: No. IE install: No. –  Dave Forgac Nov 5 '09 at 13:55
    
I later found that the user had upgraded the system to IE8 immediately before this problem started. Reverting to IE7 didn't correct the problem however. –  Dave Forgac Jan 19 '10 at 4:07

4 Answers 4

up vote 1 down vote accepted

I found the IE 8 wasn't fully installed. It had supposedly installed with a group of Windows Updates. I even got the IE Welcome dialog but when I checked About it was IE 7. I did the download from MS but I'm not sure what actually kicked off the IE 8 Installation. Once IE 8 installed my error when away.

share|improve this answer

To fix this issue download and install the lastest IE8 from http://www.microsoft.com/windows/internet-explorer/worldwide-sites.aspx and do not remove anything before doing so

share|improve this answer

I don't know if this helps, but here is a few explanations about what error 54 is on windows.

# for decimal 54 / hex 0x36 :
  DEVICE_REFERENCE_COUNT_NOT_ZERO                               bugcodes.h
  MSG_DN_CERT_PENDING_WITH_INFO                                 certlog.mc
# Certificate Services left request %1 pending in the queue
# for %2.  Additional information: %3
  CR_DEVICE_INTERFACE_ACTIVE                                    cfgmgr32.h
  POLICY_ERRV_USER_CHANGED                                      lpmapi.h
  NRC_MAXAPPS                                                   nb30.h
# /* max number of applications exceeded        */
  NMERR_INVALID_NETWORK_ID                                      netmon.h
  OLE_ERROR_SETDATA_FORMAT,                                     ole.h
# Server app doesn't understand the       */
  ERROR_NETWORK_BUSY                                            winerror.h
# The network is busy.
  LDAP_LOOP_DETECT                                              winldap.h
# for hex 0x54 / decimal 84 :
  LM_SERVER_INTERNAL_ERROR                                      bugcodes.h
  MSG_E_INVALID_KRA_CERT                                        certlog.mc
# Certificate Services will not use key recovery certificate
# %1 because it could not be verified for use as a Key
# Recovery Agent.  %2  %3
  NMERR_PATH_NOT_FOUND                                          netmon.h
  ERROR_OUT_OF_STRUCTURES                                       winerror.h
# Storage to process this request is not available.
  LDAP_DECODING_ERROR                                           winldap.h
# 14 matches found for "54"
share|improve this answer

I was having the problem with IE 8 on Windows Server 2003 R2 Standard x64 edition, and I was able to fixed unistalling IE 8, we shouldn't surf in the internet on a Server Production Machine anyway.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.