Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running Windows Home Server as a Hyper-V guest. Yes, I know, its quite the odd setup...

What I'm seeing is that every week or 2, the WHS guest locks up, and when I try to reboot it from the Hyper-V console, nothing happens. I can't reset it, turn it off, shut it down - nothing works. My only solution when this happens is to reboot the host. I'm running a mix of other VM's on the host as well - all are either win2008 x64 or win2008 x86 - and I don't have this same problem with any of those guest machines.

Any suggestions as to where i should start in solving my problem? My first inclination is to reinstall the Hyper-V integration components in the WHS guest. After that, i'm not sure what to try.

share

locked by HopelessN00b Dec 5 at 9:27

This question exists because it has historical significance, but it is not considered a good, on-topic question for this site, so please do not use it as evidence that you can ask similar questions here. This question and its answers are frozen and cannot be changed. More info: help center.

closed as off topic by Chris S Jan 27 '12 at 4:56

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

This wont resolve the problem but could save the host reboot. Save all VM states so that the only one running is your WHS. Use taskman and close the process vmwp (virtual machine worker process).

This should cause the WHS VM to restart. You can also restart your other VM's.

I have used this a couple of times on hung linux vm's.

This is not an advised best practice and your WHS event log should show further information on what is causing this issue. You could also try an upgrade to W2k R2 RC and see if that still causes the same issues (updated HyperV and VM Integration Drivers)

share
    
I tried killing the processes like you suggested - and they refused to die. I still ended up having to hard boot the host :( –  Scott Ivey May 28 '09 at 19:11
up vote 1 down vote accepted

Reinstalling the integration services components didn't help at all. The lockups seem to be either network or disk related - since they appear to happen during the schedule backups of all the PCs at my house in the overnight hours.

Based on the idea that maybe the disks were the problem, earlier this week I decided to move 2 of the 3 VHD files on the virtual SCSI to virtual IDE. I moved the 2 files that were sitting on firewire attached drives - and my WHS VM has been lockup-free since. Based on that - i'm wondering if the problem was with the firewire attached drives on the host, or with the virtual SCSI, or maybe a combination of both of those.

share
    
At least you found a resolution! Have you got access to 2k8 R2 RC? Would be interesting to see if this version suffers the same problem –  Wayne May 29 '09 at 13:05
    
i do have access, but haven't gotten around to testing that yet. Hopefully in the coming weeks i'll get a chance. –  Scott Ivey May 30 '09 at 20:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.